Can't select a custom location and name for Start Menu folder

RESOLVED FIXED in Firefox 2 alpha3

Status

()

Firefox
Installer
--
enhancement
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Jure Repinc (JLP), Assigned: rstrong)

Tracking

unspecified
Firefox 2 alpha3
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
When I am installing Firefox I would like to be able to select where to install
the Start Menu folder for Firefox icons and choose its name.

Reproducable: always

Steps to reproduce:
1. run the Firefox installer

Current results:
Firefox installer newer asks you about the location and name of the Start menu
folder. It always just creates them in "C:\Documents and Settings\All
Users\Start Menu\Programs" and names it "Mozilla Firefox".

Expected results:
Firefox installer should ask you where to put the folder and what name should it
have. So that it would be possible to create the folder in "C:\Documents and
Settings\All Users\Start Menu\Programs\Internet" and name it "Firefox" for example.

Comment 1

13 years ago
Moving the shortcuts manually afterwards is bearable (although Windows almost
crashes), but it means that after uninstall, dead shortcuts are left to be
mopped up.
Confirming. Involves quite a bit of work, so probably will have to wait till 1.5.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
I'm always annoyed when a CUSTOM INSTALL doesn't offer the choice of changing
the default location in Start Menu\Programs\ for the new shortcuts.
Ideally this could be fixed at the same time as bug 245392.

Bug 250915 is a dupe of this one, but since I voted for it, I cannot mark it as
such even thought I removed my vote...
*** Bug 250915 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
(In reply to comment #2)
> Confirming. Involves quite a bit of work, so probably will have to wait till 1.5.

Need target milestone of 1.5 to put this in then.  ;-o

Comment 6

13 years ago
(In reply to comment #2)
> Confirming. Involves quite a bit of work, so probably will have to wait till 1.5.

Surely all that's required is to add a single extra pane to the installer program which gets a string from 
the user asking where to shove the thing in the start menu? Then you can simply apped this to
"C:\Documents and Settings\All Users\Start Menu\Programs\" and tell the installer to stick the start 
menu items there.

Or am I missing something here?

Updated

12 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
Though additional work needs to be done on the NSIS installer this bug should be fixed by bug 326580
Blocks: 339061
Assignee: nobody → robert.bugzilla
Fixed by the checkin of bug 326580.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 2 alpha3
You need to log in before you can comment on or make changes to this bug.