Submiting comments to bug 18574 takes forever

RESOLVED WONTFIX

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WONTFIX
14 years ago
6 years ago

People

(Reporter: Peter Weilbacher, Assigned: myk)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040519
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040519

When I add a comment to bug 18574 and press Commit this operation never
completes. I see Mozilla's throbber working and after a few minutes I also get
the email containing the change I did. After 5 to 7 minutes I cancelled the
operation (by pressing the stop button).

I suspect there is a problem with Bugzilla for bugs with many comments, long CC
lists or something like that.

I noticed this problem with both Mozilla trunk (OS/2 build, 20040612) and
Mozilla 1.7 branch (version above).

Reproducible: Always
Steps to Reproduce:
It's the long CC lists.  To be precise, there's 131 people on the CC list, and
693 people have voted on that bug.  Plus the reporter, QA, and assignee, makes
827 people to send mail to, and that's not even counting anyone who happens to
be watching any of the above 827 people.

There is stuff in the works to alleviate this (going into the redesign of the
mail system happening in bug 84876) but that's probably a month or two off at
least.  In the mean time we have a cron job running to ensure that all of the
mail gets sent. (usually the first 4 or 5 hundred people on the list actually
get mail, and the rest don't because it times out and Apache kills it)

The resolution I'm setting is just a technicality to get this bug out of the
way, because it's not quite a duplicate, yet it is being taken care of
elsewhere.  The problem will get taken care of, don't worry. :) As long as that
cron job keeps spewing mail at me every night complaining that it found bugs
with unsent mail, this is quite high on the radar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.