The procedure entry point ??_7nsQueryInterface@@6B@ could not be located in the

RESOLVED WORKSFORME

Status

()

Toolkit
Startup and Profile System
--
critical
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Richard Hughes, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608
Build Identifier: Cannot complete since will not start.  Is latest version (0.9) of FireFox

The procedure entry point ??_7nsQueryInterface@@6B@ could not be located in the
dynamic link library xpcom.dll

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
I did load a number of add-ins, so it is probably one of these causing the problem

Expected Results:  
Application actually starts up and runs!

Comment 1

14 years ago
Did you uninstall Firefox 0.8 before installing 0.9?

Also, can  you try to run Firefox in safe mode (start menu/programs/firefox)?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Did you uninstall Firefox 0.8 before installing 0.9?
> Also, can  you try to run Firefox in safe mode (start menu/programs/firefox)?

1) I did not have Firefox 0.8 (or earlier) installed, so n/A.

2) No, the application will not run in safe mode either.  I get no error 
message and there is no visual sign that the PC has done anything.  From 
Windows Task Manager in Processes I see that firefox.exe is consuming 8,012k 
of memory and yet if I look at Applications there is no mention of Firefox.

3) Firefox initially installed and ran OK, but upon adding a number of add-ins 
the program would not start again.  I did not re-start after adding each add-
in so I do not know if the problem is caused by a particular add-in or is due 
to an accumulation problem.

4) I did un-install Firefox 0.9 using add/remove programs, re-started and re-
installed Firefox 0.9 - Program still would not start up. 

Comment 3

14 years ago
I am having the same problem.  On initial installation the browser opened right
up, but after installing about 7 plug in extensions, and then trying to reopen,
it won't.  I also tried uninstalling and reinstalling stil won't.  I am running
Windows XP PRO.   

Comment 4

14 years ago
I have precisely the same problem. .
The browser (Firefox091) was working very well, but now it won´t start anymore
after installing a  couple of extensions (around 10).  I have tried unistall,
installing  agai, and re-starting the computer but to no avail. However, the
task manager (windows XP) tells me that the program is running.. 
The only problem I had previously had was when ussing the IE-View extension: I
automatically wass redirected towards Internet Explorer without being able to
use Firefox. I had  to uninstall that extension en then it was OK..

Comment 5

14 years ago
Can you reproduce this with a new profile, now that Safe Mode and reinstalling
doesn't work?
http://kb.mozillazine.org/index.phtml?title=Profile_Folder

If not, ->WORKSFORME.

Comment 6

14 years ago
I've moved to Startup and Profile System and edited the Summary to be more
specific.  Does this still happen in 0.9.2?
Component: General → Startup and Profile System
Summary: Will not start up → The procedure entry point ??_7nsQueryInterface@@6B@ could not be located in the

Comment 7

14 years ago
No response from user -> WFM.

If you can follow the instructions above with the latest version and still
reproduce, reopen this with more details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.