If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can not close preferences-dialog with "OK" if Home Page Location is changed manually

RESOLVED DUPLICATE of bug 246354

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 246354
14 years ago
11 years ago

People

(Reporter: Markus Amersdorfer, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

When changing the "Home Page Location(s)" field manually by entering another
web-page or by simply changing the existing string, "OK" does not close the
Preferences window and it is impossible to save the changes.
Using the buttons such as "Use current pages" works fine.

I first came accross this bug in Firefox 0.9rc1, but it might have been
introduced earlier already.

Reproducible: Always
Steps to Reproduce:
1. Using a fresh profile, start Firefox 0.9, open "Edit -- Preferences".
2. Change the content of "General -- Home Page -- Location(s)", e.g. to your
favorite search engine. (Enter the URL manually.)
3. Try clicking "OK" to save and exit the preferences dialog.

Actual Results:  
Nothing.

Expected Results:  
Saved the changes and exited the preferences-dialog.

Comment 1

14 years ago
(In reply to comment #0)

I have been able to reproduce this. Did not occur prior to 0.9rc

UA: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Comment 2

13 years ago
I've the same problem, though I'm not sure from the description if it's an exact
match; only one of three of the buttons will allow me to change the default
blank to any given page (to wit, the Use Current Page button). Installed version:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 236354 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 246354 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 5

13 years ago
236354 is about Xinerama and IMHO has absolutely nothing to do with this bug. 
Not even remotely.  Leaving as resolved per duplicate bug 246354 (10' diff!)
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.