Closed Bug 246893 Opened 17 years ago Closed 17 years ago

Web pages in background tabs still focus

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: xslaugh, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

If you are browsing a web page and then open one in a new tab such as
www.hotmail.com that focuses on a field when it comes up, the focus is stolen
from the current web page.  So, I can open my new page and type in my old page
until the new page finishes loading.  Once it finishes loading, whatever I type
is suddenly typed into the field that is focused on in my other tab.

Reproducible: Always
Steps to Reproduce:
1. Open web page with fields.
2. Open another web page in new tab with a field that is focused on.
3. Start typing in the first web page.
4. Wait for the new page to finish loading.

Actual Results:  
Focus is given to the page in the other tab, and your text is placed there.

Expected Results:  
Keyboard focus should have remained on the web page in the active tab.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.