CPU usage reaches 99% and will not go down

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: dwz, Assigned: bugzilla)

Tracking

unspecified
x86
All
Points:
---
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

I've had this problem in the last few version of Mozilla (0.9, 0.8, 0.7). 
Firefox starts without a problem and I can browse webpages fine.  After what
appears to be a random amount of time (maybe 20 minutes?) Firefox jumps to 99%
CPU usage and will not go down.  It still loads pages fine (slowly, but fine),
everything works as expected yet it is at 99% and all my other programs stop
working.  There is no perticular trigger that I can identify, it appears to be
random.

Reproducible: Sometimes
Steps to Reproduce:
1. Load Firefox
2. Start surfing
I know these steps are hardly going to result in a problem for everyone, but
that's what is happening for me.

Actual Results:  
CPU usage of Firefox goes up to 99%.

Expected Results:  
Stayed at its usual rate of <5%.

I know I am giving little information here, but I really don't know what I
should be saying.  I can't identify anything that is causing this.  I guess I'll
give my system specs, maybe there is something strange there:

Windows XP Pro SP1 (all windows updates)
Inspiron 8200 Laptop
1.9 Ghz P4 processor
512MB DDR RAM
40GB HDD (over three partitions, still 15GB free)

I'm not running any really strange applications in the background.  Norton
AntiVirus, Office 2004, Winamp.

Not sure if it's related, but I use a proxy server to access the internet.

If there is any information that you think would be relevant, please tell me and
I'll try and give it.
(Reporter)

Comment 1

14 years ago
Created attachment 150887 [details]
Windows Task Manager - Processes screen
(Reporter)

Comment 2

14 years ago
Created attachment 150888 [details]
Windows Task Manager - Performance screen
(Reporter)

Comment 3

14 years ago
err, just noticed I said "last few version of Mozilla" - I mean "last few
version of Firefox/Firebird".

I have also tried to reproduce this bug in Mozilla (v1.7 - Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514) but can't get it to happen.

Comment 4

14 years ago
This is _always_ true for me, it's just a matter of how long you must wait.

I never close Mozilla/Firefox.  After some time (sometimes hours, sometimes
days) the CPU utilization reaches 99%.  At that point, I bookmark all open tabs
(using the date as the bookmark name) then restart.

I've tried building Moz/Fir hoping to be able to debug, but it was beyond me.

Anyone know where to get a DEBUG version - that might have a debug console, or
spit out some extra info?  This _really_ needs to be fixed.

-- Patrick Anderson

Comment 5

14 years ago
Can you be more specific (as in try to pinpoint when Firefox jumps in CPU)? The
reason for that is that, generally, non-specific bugs are marked as invalid, and
it'd be better if this turned into a new bug or a duplicate.

Comment 6

14 years ago
I hate to jump browser types, but don't see a more specific place to report this.
Same issue here with Mozilla 1.7 - gentoo ebuild.
Both machines experiencing same problem.  After an indeterminate period of web
browsing, no matter what we're doing, eventually jumps to consuming all
available CPU until killed.
Open to suggestions for how to get more information.

Comment 7

14 years ago
see also bug 233573 and bug 235865?
It seems not an insignificant number of people are experiencing this.
(Reporter)

Comment 8

14 years ago
So, is there some kind of debug version of Firefox that I can use?

This is becoming a *major* problem for me.  I want to help and give more
information, but I just don't know how to without some kind of debug version. 
I'm more then happy to run some debug version which makes a 100MB log file and
upload it to wherever it's needed.

But it's a random bug, I can't find any trigger, so I don't know how else I can
give any more details.

Updated

14 years ago
Depends on: 216288

Comment 9

14 years ago
I'd like to agree on the major problem front.
I'm having a hard time keeping my S.O. using Mozilla, this is pretty much a
deal-breaker for her.  She's used to leaving her browser open, and while it is
random, it seems to happen at the worst possible time, when she has some
composition she's been working on for a long time.
My solution *would* be to bump her back to a Mozilla that was more stable, maybe
1.4, but I don't konw if those are maintained, security patch wise.

I'd mark this bug confirmed if only it wasn't so hard to pin down...

Comment 10

14 years ago
*** Bug 255525 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
There is recently ongoing discussion in Firefox Bugs forum:
http://forums.mozillazine.org/viewtopic.php?p=1015251
There are backtraces of slowdowned firefox which show lots of calls of
nsPRUint32Key::Clone(). Sleepingsquirrel has found in the code around this place
the following comments:

// XXX This method was called _hashEnumerateCopy, but it didn't copy the element!
// I don't know how this was supposed to work since the elements are neither 
// copied nor refcounted. 

// XXXbe must we clone key? can't we hand off 

// Pray we don't dangle! 

and most importlantly, I think:
/**
 * nsHashtable is OBSOLETE. Use nsTHashtable or a derivative instead.
 */ 

Could that be the reason?

Comment 12

14 years ago
Created attachment 167438 [details]
Four backtraces for FF 1.0 under the 100% CPU usage condition

I've attached a file with four different gdb backtraces of FF 1.0 when its been
sitting at 100% CPU.  Is it normal to have so many deeply nested stack frames
for nsPRUint32Key::Clone()?  It is definitly repeatable, in the sense that
letting FF run long enough causes the problem (usually less than 5 hours on my
machine). Anyone have recommendations for additional work we can do to help
resolve this bug?

Comment 13

14 years ago
We should change the OS field on this from "WinXP" to "All" since it is
reproducible on Linux.  See also the MozillaZine forum link in Jan Valenta's
note above.

Comment 14

14 years ago
This is happening to me, too...
now and then FF jumpt to 100% of CPU.
I've not found a pattern in the action I do to make it jumps to 100%, but seems
that it mainly occurs where there are some problem with the page I'm downloading
(slow responding parts of the page like images or js) and I try to do something
on the GUI of the program (close the tab, clicking on some menu, opening another
tab, and so on...)
This started to happen just a few days ago (while I installed FF 1.0 the 9th of
November) but I did nothing on the PC (didn't install anything, no programs or
patches)

Comment 15

14 years ago
ops... I forgot to mention: I'm using WinXP SP1

Comment 16

14 years ago
Same problem here. It started happening a week or two after I upgraded from 98SE
to XP with SP2. I upgraded Mozilla to 1.7.3 and again to 1.7.5. I cannot
consistently reproduce it.

Comment 17

14 years ago
I'd like to know what is going on with this bug, because this bug is very
irritating, since it hangs firefox.
What's goin on? noone from the FF team noticed this error?
Is there something I can do to help debugging the problem?
Does what stated in attachment 3 [details] [diff] [review] an comment #11 are a possible cause of the problem?

Updated

14 years ago
Flags: blocking-aviary1.1?
(Reporter)

Comment 18

14 years ago
This problem seems to be affecting a number of operating systems, so changing 
OS from WinXP to ALL.
OS: Windows XP → All

Comment 19

14 years ago
Computer starts to get blocky, task manager shows firefox.exe at 99%, blank page
was loaded (default home page), no other pages loaded in background.

System was inoperable, 'End Task' did not function, had to kill process
firefox.exe, upon reload things run flawless for hours.

Tried to do a fresh install, deleted registry entries, hidden profile
directories, and program directory, and upon loading the program it still occurs. 

On my desktop system, I have never had this problem at all whatsoever, it's the
strangest thing. Perhaps the intel speedstep problems?
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 20

13 years ago
I have this problem, too. Using a Winbook X540 with XP SP2. Always happens after
a while.

Comment 21

13 years ago
Just adding another "me too" for this.  Quite frequent CPU hogging under Win2000.

Comment 22

13 years ago
(In reply to comment #0)
> Not sure if it's related, but I use a proxy server to access the internet.

Are you by any chance using the Automatic Proxy Configuration option?  I get the
same CPU usage pattern when I use that option.  However, once the page has been
fully loaded, the CPU usage goes back down.
(Reporter)

Comment 23

13 years ago
(In reply to comment #22)
> Are you by any chance using the Automatic Proxy Configuration option?

Nope, proxy address/port manually entered into settings.

Comment 24

13 years ago
(In reply to comment #23)
> (In reply to comment #22)
> > Are you by any chance using the Automatic Proxy Configuration option?
> 
> Nope, proxy address/port manually entered into settings.

Darn, then that's a different problem altogether.  Back to search :)

Comment 25

13 years ago
Windows 2000 SP4 with Firefox 1.0.6. Similar problem however what I see is that
the CPU usage gets pegged when I load a page. 

Sometimes it eventually recovers. More often, it has to be killed and restarted. 

This happens in conjunction with memory utilization going higher and higher
(typically about 250MB or so by the time this happens). 

Comment 26

13 years ago
mozilla-i686-pc-linux-gnu-1.7.11-gtk2+xft.tar.gz did the same thing several times!
mozilla-i686-pc-linux-gnu-1.7.11.tar.gz is OK. This was the first time I
experienced this behavior with Mozilla (I have probably never used gtk2 build
before).

Is the gtk2+xft stuff somehow included in Windows builds?

May be it is not related to this bug, but I think it is worth to mention.

I am using Slackware.

Comment 27

13 years ago
I'm at least experiencing this in 1.0.4 and 1.0.6.

I thought it was due to many extensions or stuff.


WindowsXP SP2 - 3200+ - 1024 MB

Comment 28

13 years ago
Created attachment 198633 [details]
Brief system description, a stack backtrace and some related URLs

I'm seeing this probem in Firefox 1.0.7 and have been suffering with it since
early Mozilla days.  I'm creating and deleting browser tabs all the time and
suspect that this may somehow be associated with the problem.  My attachment
provides a brief system description, a stack backtrace from GDB attached to a
nearly unresponsive Firefox, and a few URLs from people elsewhere seeing the
same problem.

Comment 29

13 years ago
Is there any way to find out just what Mozilla is doing in
memory that would make it freeze like this? (Just froze for
a second.)   

Btw, isn't this a similar bug to 233573?  

Sorry, fwiw, it is *irritating* has heck.  And there's little
I can do to predict it.  Reproduction of it is simple, but
I can't tell what conditions are required to have this
program freeze.   Literally, CPU hits 100%.  

Mozilla 1.7.12.  Win2kPro SP4, 512MB Ram.  P4 2.4.  

Comment 30

13 years ago
I'm having the same problem. It started in the 1.5 pre-releases and has continued. I have the problem on both my home laptop and work PC. I'm happy to provide any diagnostic info if someone will suggest what to provide.

Comment 31

13 years ago
Created attachment 214296 [details]
cachegrind output of a 100% CPU page load

I've found a similar bug, and attached a cachegrind output
of firefox 1.5.0.1 while loading a critical page
(to see where the cpu time is spent).

The bug has been tested with various version of firefox
(from 1.0.1 to 1.5.0.1) in both linux and windows.

The page load time is always fast in IExplorer (under 10 seconds).
In firefox varies from 10 seconds to over 7 minutes,
with the cpu at 100%, depending on how fast the CPU is
and how long the page download takes.

It seems that when the page source download takes more than 40
seconds, the browser freezes at 100% of CPU for some minutes,
even if all the data has been transferred and there is no more
network activity.

Is this the same bug reported here?

I've saved the output of the page that causes these random hangs here:

http://carpidiem.it/~diegoliz/page26.do.html

Please, tell me if you need more info or if I have to open another bug.

Comment 32

13 years ago
(In reply to comment #31)
No, this is not your bug because your processor usage goes after some time. This bug is about the browser ending up in a state where it will use all the CPU and never go down.

Updated

13 years ago
Attachment #214296 - Attachment is obsolete: true

Comment 33

12 years ago
Another ditto here. The lockup seems random, cpu usage goes high - 95 -99% - but memory usage doesn't seem to spike. Been going on for the last few revs - pulled down Firefox 1.5.0.4 today, and will see.

Doesn't seem to matter what else is running, although usually it's just my mail client. Background tasks include MS Anti-spyware (have tried running with it off, and problem still happens), Avast anti-virus, Zone Alarm and some other desktop utilities.

Windows XP home, SP2, Athlon 1.4, 768 meg ram, current video drivers, and older versions of Firefox were very happy.

Comment 34

12 years ago
Created attachment 224272 [details]
gdb backtraces during bog-down behavior

These backtraces and related info were captured while Firefox was in the middle of the bogged-down behavior in question.

Comment 35

12 years ago
It happens with Firefox 2.0.0.1. I noted that after some activity, browsing, etc., after a random time, it could be half an hour to 2 or three hours, CPU activity jumps to 99%. I can still navigate, use my browser but it will not scroll the window with the mouse wheel but I must drag the window cursor. It also doesn't show the list of recent sites now extract them while i begin typing on the URL text box. When I close Firefox, it signals an error that is transmitted to MS.
Then, when I restart it, everything works OK. The computer where this happens is an Athlon 2 Ghz, hdd SATA 150 Gb, 512 Mb RAM, Windows XP PRO SP 2.
On my laptop (SONY Waio vgn-n11s, Intel T2050 1,6 ghz, 1 gb RAM, hdd 120GB with Windows XP Media center SP2) it never happens.
Comment on attachment 224272 [details]
gdb backtraces during bog-down behavior

This trace has no useful symbols.
Attachment #224272 - Attachment is obsolete: true
This bug has long outlived it's usefulness. Please open new bugs on issues any issues that are still reproducible in recent builds.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 38

11 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
> Gecko/20040614 Firefox/0.9
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
> Gecko/20040614 Firefox/0.9
> 
> I've had this problem in the last few version of Mozilla (0.9, 0.8, 0.7). 
> Firefox starts without a problem and I can browse webpages fine.  After what
> appears to be a random amount of time (maybe 20 minutes?) Firefox jumps to 99%
> CPU usage and will not go down.  It still loads pages fine (slowly, but fine),
> everything works as expected yet it is at 99% and all my other programs stop
> working.  There is no perticular trigger that I can identify, it appears to be
> random.
> 
> Reproducible: Sometimes
> Steps to Reproduce:
> 1. Load Firefox
> 2. Start surfing
> I know these steps are hardly going to result in a problem for everyone, but
> that's what is happening for me.
> 
> Actual Results:  
> CPU usage of Firefox goes up to 99%.
> 
> Expected Results:  
> Stayed at its usual rate of <5%.
> 
> I know I am giving little information here, but I really don't know what I
> should be saying.  I can't identify anything that is causing this.  I guess
> I'll
> give my system specs, maybe there is something strange there:
> 
> Windows XP Pro SP1 (all windows updates)
> Inspiron 8200 Laptop
> 1.9 Ghz P4 processor
> 512MB DDR RAM
> 40GB HDD (over three partitions, still 15GB free)
> 
> I'm not running any really strange applications in the background.  Norton
> AntiVirus, Office 2004, Winamp.
> 
> Not sure if it's related, but I use a proxy server to access the internet.
> 
> If there is any information that you think would be relevant, please tell me
> and
> I'll try and give it.
> 

This problem is so bad that it is a "deal-breaker".  It renders Firefox totally unuseable within a few minutes of opening and with only window/tab open with no ongoing updates or downloads and without any gif's, Google calenders or any of the other specifics associated in some other bug reports on this issue.  The problem has existed for as long as I can remember (Phoenix 0.8 was my first experience but I don't remember the problem with it).  I know that it has been around since Firefox 1.0 and it has gotten noticeably worse with each release since then.  As of version 2.0, it is 99% unuseable.  The Ook Video downloader is the ONLY reason I have not simply uninstalled Firefox and launched my own counter-evangelism campaign.  Yes, this persistently worsening problem really has made me that frustrated over the years.

This bug has existed in every XP machine that I have seen - four of mine and five belonging to friends.
You need to log in before you can comment on or make changes to this bug.