Ctrl+Shift cannot be used to align text

RESOLVED DUPLICATE of bug 98160

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 98160
14 years ago
14 years ago

People

(Reporter: Snir Hassidim, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

Ctrl+Shift cannot be used to align text, usually in forums/forms. Even in this
"Details" textbox. In left-to-right based pages you cannot use the right
Ctrl+Shift to type from right-to-left, and in right-to-left based pages you
cannot use the left Ctrl+Shift to type from left-to-right; this gets very
annoying when you try to post a link in a forum, trying to type it from
right-to-left with the [URL] and the [/URL]. Whenever I want to post replies or
threads (mostly in right-to-left based pages) I have to use the Microsoft
Internet Explorer or the Notepad.

Reproducible: Always
Steps to Reproduce:
1. Enter any site that includes a textbox, such as a form, or a forum post textbox.
2. Click the textbox, so you could type in it.
3. If the site you are viewing is using left-to-right code
(English/French/Spanish... sites) (the text marker shows on the left side of the
textbox), try pressing the right Ctrl+Shift.
4. If the site you are viewing is using right-to-left code (Hebrew/Arabic sites)
(the text marker shows on the right side of the textbox), try pressing the left
Ctrl+Shift.
Actual Results:  
The textbox wasn't aligned to the other side.

Expected Results:  
The textbox marker should have moved to the other side of the textbox, allowing
typing from right-to-left on left-to-right pages, or left-to-right on
right-to-left pages.

Comment 1

14 years ago
Bug 85420 comment 26 has a workaround.

If you know Hebrew (sorry, I don't), you might find an explanation on
<http://wiki.mozilla.org.il/index.php/%D7%9B%D7%99%D7%95%D7%95%D7%A0%D7%99%D7%95%D7%AA_%D7%93%D7%A3>

*** This bug has been marked as a duplicate of 98160 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.