firefox 0.9: linux system requirements specify wrong minimum glibc and gtk+ version

RESOLVED WORKSFORME

Status

www.mozilla.org
General
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Rainer Bawidamann, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Opera/7.51 (X11; Linux i686; U)  [en]
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.9/firefox-0.9-i686-linux-gtk2+xft.tar.gz

the firefox 0.9 binary for Linux is compiled against Glibc 2.3 while the
system requirements document says it needs Glibc 2.2.

I would appreciate if you could provide binaries compiled against glibc 2.2
(but I understand if you don't want to spend the effort for a beta version).
If not please describe on the web page that the binary is compiled against
Glibc 2.3 (thus i won't run on Debian stable/3.0/woody).

Thanks, Rainer

PS: The -installer version might have the same problem: The installer starts up,
but fails with an error that it cannot find/run a file.

Reproducible: Always
Steps to Reproduce:
Download binary for firefox 0.9/Linux. Run on Debian stable/3.0.
Actual Results:  
error message:
./firefox-bin: /lib/libc.so.6: version `GLIBC_2.3' not found (required by .
/firefox-bin)

Comment 1

14 years ago
I observed the same problem with firefox release 0.9 and the current nightly
(27-Jun-2004) on a SuSE 8.1 machine which also has Glibc 2.2 (not 2.3).

The same happened some months ago with mozilla and thunderbird builds, see Bug
#227105
(Reporter)

Comment 2

14 years ago
Update: firefox 0.9.1 requires GLIBC 2.3.2

Could you please either build firefox on a host with GLIBC 2.2 or mention in the 
release notes/announcement that the pre-built images require GLIBC 2.3? Thanks.
The system requirements also say "gtk+ - 1.2.0 ( 1.2.5 or greater preferred)" is
required but the binary distributions seem to need gtk+ 2.x at least. 

Changing the summary to be more general. 
Summary: firefox 0.9: system requirements say glibc-2.2 but linux binary needs glibc-2.3 → firefox 0.9: linux system requirements specify wrong minimum glibc and gtk+ version
BTW the README.txt file that comes with the tar.gz distribution is wrong too. 
(Reporter)

Comment 5

13 years ago
The "system requirements" page now lists glibc 2.3 and gtk 2.0.

I think this bug can be closed.
Can you confirm that all cases of this has been fixed? README.txt and the system
requirements page have been mentioned.

If so, please mark as WORKSFORME.

Comment 7

13 years ago
http://www.mozilla.org/products/firefox/releases/#requirements links to
http://www.mozilla.org/products/firefox/system-requirements.html, which mentions
glibc 2.3.2 and gtk+2.0.

README.txt has been stripped down:
http://lxr.mozilla.org/seamonkey/source/browser/locales/en-US/README.txt

-> WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
--> Websites :: www.mozilla.com so timeless can close out Firefox :: Product Site.
Component: Product Site → www.mozilla.com
Product: Firefox → Websites
QA Contact: www-mozilla-com
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.