Use better algorithm when completing addresses from collected addresses

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED WORKSFORME
14 years ago
4 years ago

People

(Reporter: Laurent Duperval, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040415 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040415 Firefox/0.8

Hello,

I've set TB (0.6) to collect addresses when I send a message. This creates an
annoyance when address completion takes information from the collected
addresses. I would like TB to be more intelligent about the first email address
to show.


Reproducible: Always
Steps to Reproduce:
For example, if I send a subscription request to a mailing list, I will send it
like this:

To: list-request@listserver.com

I get a reply to which I must respond in order to be added to the list so I
reply to the same address.

Now, whenever I want to send messages to the list I must send them to 

list@listserver.com


Actual Results:  
When I type the start of the email address, the first one to show is always
list-request@listserver.com. I can understand why it does that the first time,
but I would like list@listserver.com to appear first after a while.



Expected Results:  
TB should realise that I'm using list@listserver.com more often than
list-request@listserver.com. It should then do the completion of list@ before
that of list-request@

Comment 1

14 years ago
I couldn't find a duplicate, so marking as NEW.
Similar bug for address bar is bug 182366.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Blocks: 168902

Updated

14 years ago
OS: Linux → All
Hardware: PC → All
QA Contact: message-compose

Updated

10 years ago
Assignee: mscott → nobody

Comment 2

8 years ago
this has since been changed to complete based on frequency of use (although it's broke in version 3)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.