folder size column doesn't update when deleting messages

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Amos Shapira, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: version 0.6 (20040502)

I added the "Size" column to the folder list pane on the left of the screen.
The sizes in this window do not reflect deleting of messages until after another
folder is selected and then the older folder is re-selected.
 -
the size of folder "A" is updated only when I re-select.


Reproducible: Always
Steps to Reproduce:
1. select folder "A"
2. delete one or more messages in folder "A" - notice that the reported size
haven't changed.
3. select folder "B" 
4. re-select folder "A"
Now you'll see that the size was updated.

Actual Results:  
The folder size was updated only after step (4).


Expected Results:  
I'd expect the folder size to update after step (2).


I access my mail on a courier-imap server 3.0.3 (debian revision 3) through imap
over ssl.

I marked this a "Minor" because the "re-select" might be regarded by some as
"an easy workaround".

Comment 1

14 years ago
Using version 1.0 (20041206)

when reproducing the bug, the folder size in NEVER updated : step 3 and 4 not
reproduced.
I need to restart TB to get the correct folder size.

Comment 2

13 years ago
For me, even restarting doesn't help. I need to compact folders to get the
correct sizes.

It's funny if you have no messages in Inbox, but the reported size is a few Mb.

Comment 3

13 years ago
the intent of the folder size column is to show you the size on disk. Deleting a
message doesn't affect the size on disk until you compact the folder. Thus, the
current behaviour is the intended behaviour.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
Does changing to another folder and back to the first compact the folder?

I don't use Thunderbird now so I can't test it any more.
You need to log in before you can comment on or make changes to this bug.