background-repeat: no-repeat; is ignored when not inline with background:

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: Jon Stevens, Assigned: dbaron)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040602 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040602 Camino/0.8+

i'm going to upload an example .zip file with just a really basic CSS example.

if you move the background-repeat: no-repeat; from the index.html file into the
CSS, then things display properly. otherwise, they don't.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
repeat shows up

Expected Results:  
no repeat! =)
(Reporter)

Comment 1

14 years ago
Created attachment 150984 [details]
simple example showing the problem

have fun! =)
(Reporter)

Comment 2

14 years ago
just confirmed that this also occurs in firefox.
-> browser.
Assignee: pinkerton → dbaron
Status: UNCONFIRMED → NEW
Component: General → Style System (CSS)
Ever confirmed: true
Product: Camino → Browser
QA Contact: ian
Version: unspecified → Trunk
A zip file doesn't qualify as simple.  One small file qualifies as simple.

This is invalid.  Shorthand properties such as background reset all their
subproperties.  See
http://www.w3.org/TR/2004/CR-CSS21-20040225/about.html#shorthand
http://www.w3.org/TR/2004/CR-CSS21-20040225/colors.html#propdef-background
so it matters which one comes first.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

14 years ago
wow, i didn't know a zip file was too difficult for you to process.

anyway, thanks for the info...learn something new every day.

verfied not a bug.
Status: RESOLVED → VERIFIED
(In reply to comment #5)
> wow, i didn't know a zip file was too difficult for you to process.

It takes about 30 seconds to look at, as opposed to 5.
You need to log in before you can comment on or make changes to this bug.