Multi addr header widget doesn't toggle after a few times.

VERIFIED FIXED in M14

Status

SeaMonkey
MailNews: Message Display
P2
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: laurel, Assigned: Eric Vaughan)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-]Have a fix testing)

(Reporter)

Description

19 years ago
Using jan21 builds on NT 4.0, linux rh6.0 and mac OS 8.5.1

The widget which appears in a displayed message where the are more than a couple
addressees doesn't toggle more than a few times if the addressee list spans more
than one line when displayed in long form.  Once the widget is in the state
where it won't toggle, clicking it will result in clicking the mailto
link/header and will open a compose window accordingly. 

1.  Launch 5.0 and go to mail, login to mail account with proper password.
2.  Select a message in mail folder which has several addressees in one type of
address header (i.e. a message which has 5 email addresses in the To: or 5 email
addresses in the cc:) . 
3.  Click on the triangle widget appearing at the end of the To:, CC: or other
header line which has been collapsed to a few displayed addressee headers.  This
should cause the full list of address headers to display.
4.  Click on the triangle widget again to collapse the header line again.
5.  Repeat a couple time to toggle the addressee header line collapsed/expanded
state.

Actual Result:  After a few times you can't toggle any more. Click on widget
will translate to clicking on header/mailto link and compose window will open.
(subsequently you will probably hit another bug #23782).

Expected Result:  Should be able to toggle as many times as you wish.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel

Comment 1

19 years ago
I think Scott has a bug on this code already. Reassigning to him, cc rhp.
Marking M14, but not beta stopper.
Assignee: phil → mscott
Priority: P3 → P2
Target Milestone: M14

Comment 2

19 years ago
Adding hyatt to the cc list.

 I'm using visiblity-collapse to hide the long email address header view. I show
the long header view, then  toggle back to the short view and use
visiblity-collapse to hide the long email addresses again, the actual content is
still there. i.e. visiblity-collapse isn't really collapsing the content. It's
hidden all right, but if I guess where the titled button for an email address in
the long view should be and I click on it, sure enough the button gets clicked
as if it were visible.

I hope my explanation makes sense. This may end up going to XP-toolkit. I'll
play around with visiblity-collapse a little more first.
Status: NEW → ASSIGNED

Comment 3

19 years ago
Sounds like this may be evaughan's bug.

Comment 4

19 years ago
Apparently the problem with dynamic overlays that broke this was fixed by
waterson yesterday. so this should be fixed in today's builds.


Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
I've been trying to find this bug all morning long! I thought I had hallucinated
it's existence. And here I accidentally marked it fixed. The comments I put
above about dynamic overlays were for another bug I must have added them here by
mistake.

re-opening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

19 years ago
Status: REOPENED → ASSIGNED

Comment 6

19 years ago
This bug is a duplicate of Bug #24543 which is PDT+ and beta1. However, this bug
has a better explanation of the problem and what's causing it. So I'm going to
transfer the PDT+ status to this bug report and mark the other one a duplicate
of this.

Re-assiging to evaughan per hyatt's comments.

Eric, the problem is that I'm using visibility collapse to hide a div inside of
a box in the message pane. The div consists of a list of titled buttons
corresponding to each email address. The content is hidden when I apply the
visibility-collapse style. However, if I "guess" where one of the email
addresses should be and click on that spot, I'll get the menu popup associated
with that titled button.
Assignee: mscott → evaughan
Status: ASSIGNED → NEW
Keywords: beta1, crash
Whiteboard: [PDT+]

Comment 7

19 years ago
*** Bug 24543 has been marked as a duplicate of this bug. ***

Comment 8

19 years ago
Jar actually crashes on Win98 when he clicks on the empty space where an email
address would be if it wasn't currently hidden. This is why [crash] appears in
the key word field.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] Possible fix awaiting checkin
(Assignee)

Comment 9

19 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

19 years ago
I still am not able to toggle the address header widget after a few times if the
expanded list spans two lines; original problem still exists.  When I can no
longer toggle, there is a popup menu with choices to Send mail to, Add to Addr
Book or Send and Instant Message.

Reopening.  I found NT worked a little better than my linux; I could toggle a
few more times on NT before hitting the problem condition.

Using:
2000-02-10-15m14 commercial build on linux rh 6.0
2000-02-10-14m14 commercial build on NT 4.0 
having trouble with my mac, will retest that platform shortly.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

19 years ago
Whiteboard: [PDT+] Possible fix awaiting checkin → [PDT+] Hmmm. This is wierd. Looking again.

Comment 11

19 years ago
Removing PDT+ for reconsideration. We knowingly shipped 4.5 with at least one
platform only able to toggle this control _once_, and I don't recall anyone
being too broken up about it.  If anyone needs to toggle it more than once for
some strange edge-case reason, then there is a simple workaround (select another
message, then this message again).  This scenario is so remote as to barely be
worth release-noting for beta. It is not worth delaying the release, ignoring
other defects and risking regressions for.

As to the 'crash', neither this bug nor 24543 includes steps to reproduce a
crash, and in fact using current comm opt build on Win98, and an hour-old debug
tip build on Linux, I can toggle the control many times without any problems.
I'd resolve as WFM, but I don't have NT.
Whiteboard: [PDT+] Hmmm. This is wierd. Looking again. → Hmmm. This is wierd. Looking again.

Comment 12

19 years ago
Hmmm I do this all the time. It's really been a small usability issue for me.
Maybe I'm alone in this...

Comment 13

19 years ago
Putting on PDT- radar for beta1.
Whiteboard: Hmmm. This is wierd. Looking again. → [PDT-]Hmmm. This is wierd. Looking again.
(Assignee)

Comment 14

19 years ago
Have a fix testing
Whiteboard: [PDT-]Hmmm. This is wierd. Looking again. → [PDT-]Have a fix testing
(Assignee)

Comment 15

19 years ago
fixed
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

19 years ago
OK using:
2000-03-06-09 commercial build on linux rh6.0
2000-03-06-09 commercial build on NT 4.0
(Reporter)

Comment 17

19 years ago
OK using 2000-03-06-08 mozilla build on mac os 9.0
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.