"Mozilla thinks this message is junk mail" appears on top of wrong message when marking a different message as Junk using mouse

VERIFIED WORKSFORME

Status

MailNews Core
Filters
--
minor
VERIFIED WORKSFORME
14 years ago
7 months ago

People

(Reporter: Armin Fuerst, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.6) Gecko/20040113

While reading the messages and detecting in the list of messages a
spam-message and marking this message as junk by right-clicking on
the spam message (leaving the currently non-junk-message visible in 
the Message-Pane) and selecting "Mark -> As Junk", correctly moves 
the junk message (which is *not* displayed in the Message-Pane!)
to the junk-folder (according to the junk-mail-controls), but puts the
header "Mozilla thinks this message is junk mail" on top of the
currently selected message in the Message-Pane.
The message in the Message-Pane isn't really marked as junk, by selecting
a different message and reselecting the message, the message doesn't
get this header.

Reproducible: Always
Steps to Reproduce:
1. Have a couple of (new) messages in the list of mails, at least one that
   should be marked as junk, but isn't
2. Select by left-mouse-click any non-junk-message
3. Select by right-mouse-click the junk-message and in the Context-Menu
   select "Mark -> As Junk"
Actual Results:  
1. The junk message was correctly marked as junk (as expected).
2. The junk message was correctly moved to the junk-folder (as expected).
3. The non-junk-message in the Message-Pane got the header
   "Mozilla thinks this message is junk mail" (NOT AS EXPECTED).

Expected Results:  
1. and 2. from "Actual Results" but not 3.

Current workaround: select another message and reselect the message.
(Reporter)

Comment 1

14 years ago
This effekt still appears in:
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7) Gecko/20040616
Product: MailNews → Core

Comment 2

13 years ago
This is still happening with Thunderbird 1.0

Comment 3

13 years ago
*** Bug 287293 has been marked as a duplicate of this bug. ***
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 5

12 years ago
This bug is still existing in Thunderbird 1.0.6 (20050716) running on
Windows XP SP2. The way to reproduce is identically to the first report.
(Reporter)

Comment 6

12 years ago
This bug still exists in Thunderbird 1.5
(Reporter)

Comment 7

12 years ago
This bug can still be found in Thunderbird 1.5.0.2
(Reporter)

Comment 8

12 years ago
I also verified the bug in Thunderbird 1.5.0.4

Comment 9

12 years ago
is it happening in 2.0 nightly builds?
(Reporter)

Comment 10

12 years ago
I'm not sure, I tested the correct version, but the nightly build I
found yesterday still has this error. In Help->About it says:
"version 3 alpha 1 20060606"

Comment 11

11 years ago
does this happen in safe mode or with a clean profile?

do you see the problem if you mark message as junk with keyboard instead of mouse?
(Reporter)

Comment 12

11 years ago
It happens in safe mode (No Extensions).
I cannot check this with a clean profile, because I won't get
spam with a clean profile. If it is sufficient to have a new profile
based on the same IMAP-configuration, it is also happening.
I have no idea how I could mark a message as Junk with the keyboard
without selecting it before (which is the main point of the problem).
If there is a way, you have to tell me and I'll try it.

Comment 13

11 years ago
does the message that "should not" be junk have the junk ICON in the threadpane's junk column, in addition to the junk button in the message pane? If so, TB thinks it's junk, but it just didn't move it to the junk folder (assuming you have that preference set)

[why won't you get spam?  you'll get same incoming messages. Also, I don't actually expect to see a difference if you don't use a mouse and contect menu, but the keyboard shortcut is "J", as found on the command menu via message | mark | junk]
(Reporter)

Comment 14

11 years ago
Created attachment 244196 [details]
Screenshot to show the details

This screenshot shows what the bug is about:
The selected message is not junk (it is in real life, but I kept some
messages for tests). The junk-column does not mark it as junk,
but the message-pane itself does.
(Reporter)

Comment 15

11 years ago
Additional answer to Comment #13:
There is a big difference between keyboard and mouse usage, I'll try
to explain it in different words:
I have a list of messages and have been working on one. For which reason
ever, I leave this message in the inbox. As one of the next messages, I
recognize from the subject and/or sender a junk-message that has not been
properly detected as junk. I don't need to see the contents of the message,
so I directly right-click on it (with the mouse) and get the context menu
for the junk-message. But in the message-pane I still see the non-junk-message.
From the context menu, I now select "Mark -> As Junk", which correctly marks
the junk-message as junk and moves it directly to the junk-folder (as it is
configured). The first message I was writing about (the one I left for some
reason in the inbox) was visible the whole time in the message-pane and now
gets the header in the message-pane "Thunderbird thinks this message is junk."

With the keyboard, I would have to select the junk-message first before
I could mark it as junk, I would see it in the message-pane and everything
works fine.
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 17

10 years ago
confirmed using the steps in comment 0.
I'll leave it to someone else to decide if this should stay in filters or be moved to Thunderbird:Front End

wonder if this is in any way related to bug 353458
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
QA Contact: filters
Hardware: PC → All
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Comment 18

7 months ago
Not happening anymore. Closing as WFM.

Thunderbird 52.1.0 (32-bit)
Windows 7 64-bit
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 19

7 months ago
I agree, I just tested it with TB 45.8.0 on Linux and it's not happening anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.