The default bug view has changed. See this FAQ.

Clicking on file:/// URL doesn't open the file

RESOLVED DUPLICATE of bug 84128

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 84128
13 years ago
13 years ago

People

(Reporter: Aaron Digulla, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

Firefox cannot open file:/// type URLs when you click on them. Pasting them into
the toolbar works, though.

Reproducible: Always
Steps to Reproduce:
1. Create a small web page which contains a file URL like this:

<a href="file:C:\Some\Dir\some%20file.doc">file:C:\Some\Dir\some%20file.doc</a>

Firefox will automatically convert the URL into a valid format (as you can see
in the status bar).
2. Open the page and click on the URL. Nothing will happen!
3. Right-Click on the URL, select "Copy Link Location"
4. Paste the URL into the toolbar.
5. Press Return -> Word will start.
6. Paste the URL into the web page.
7. Open the web page again
8. Click on the URL. Nothing will happen!
Actual Results:  
Clicking on file:/// links has no effect whatsoever.

Expected Results:  
It should open the file.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.