odd text input field behaviour in flash when using wmode=transparent

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Robin Knapp, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Cursor does not change to "I" when you move over the text field in this flash movie.
When activating the text input field, no blinking text cursor is shown.
After entering some text, text selection is not possible.
There is no context menu of the text input field (with copy, paste, ...)
If you change wmode=transparent to wmode=window for example, everything works as
expected. Opening http://www.de21.de/index.swf directly works, too.

Works in other browsers (tested: IE6) when using wmode=transparent.

Reproducible: Always
Steps to Reproduce:
1. open www.de21.de
2. klick on the button
3. play around with text input field at the bottom left
Actual Results:  
mouse cursor does not change to "I"
no blinking text input cursor
text selection not possible
no text context menu
Well, the url's testcase does work, but only when you're clicking 20px or so
below the input field. See also the links when you try to hover over them. You
can see it more easily there. Not sure if this is a flash bug or a Mozilla bug
though.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Well, the url's testcase does work, but only when you're clicking 20px or so
> below the input field. See also the links when you try to hover over them. You
> can see it more easily there. Not sure if this is a flash bug or a Mozilla bug
> though.

I cannot reproduce what you described.
Mouse capturing is accurate, but there are still the problems described above.

Updated

13 years ago
Depends on: 255636

Updated

13 years ago
Blocks: 271441
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

12 years ago
Created attachment 197601 [details]
Testcase using flash from www.de21.de

As the original page does not exist anymore, I created a short html testcase.
This bug still persists in Firefox 1.0.7
I'm seeing this also with the latest nightly trunk build.
Keywords: testcase

Comment 6

12 years ago
I am not seeing the behavior with FF windows XP 1.5.0.1.
When I mouseover the text field, the cursor changes to an Ibeam.

Comment 7

11 years ago
I can confirm with firefox 2.0

Comment 8

11 years ago
I can confirm this with Firefox 2.0.1 and flash player 8 & 9 on Windows XP sp2.
Same as bug 338797?

Comment 9

10 years ago
This testcase WFM in Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9a9pre) Gecko/2007100905 Minefield/3.0a9pre ID:2007100905. Looks like it fixed. Marking WFM. Reopen if you still get it with trunk builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

10 years ago
WFM too in latest official firefox with flash 9 r47:

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Shockwave Flash 9.0 r47

You need to log in before you can comment on or make changes to this bug.