line breaks in mailto links do not show up in mail body

RESOLVED DUPLICATE of bug 220099

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 220099
14 years ago
10 years ago

People

(Reporter: Christian Wenz, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
OVERVIEW DESCRIPTION:
line breaks in mailto links do not show up in mail body

STEPS TO REPRODUCE:
1) Load the attachment or create a webpage with this code: <a
href="mailto:test@example.com?Body=line1%0A%0Dline2">link</a>
2) Click on the link

ACTUAL RESULT:
mail body is "line1line2"

EXPECTED RESULT: mail body is "line1<line break>line2"

BUILD DATE & PLATFORM: 1.8alpha1 (2004052009)

ADDITIONAL INFORMATION: it worked as expected in Netscape 4, so IMO it should
behave the same way in Mozilla.
(Reporter)

Comment 1

14 years ago
Created attachment 151010 [details]
bug demonstration

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 220099 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.