Attaching binding with SVG content on XUL doesn't work

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Alex Fritze, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
See http://www.croczilla.com/~alex/testcases/svg-in-xul/ :
In file test1.xul, <triangle> is in the xul namespace. The binding doesn't take
effect. The anonymous content is constructed ok, but it looks like that the
frameconstructor builds some xul frame -rather than an SVG container frame - for
the triangle. Result: no triangle showing.

In file test2.xul, <triangle> is in a made-up ns. Here everything is working as
expected.
Mass reassign of SVG bugs that aren't currently being worked on by Alex to
general@svg.bugs. If you think someone should be assigned to your bug you can
join the #svg channel on mozilla.org's IRC server ( irc://irc.mozilla.org/svg )
where you can try to convince one of the SVG hackers to work on it. We aren't
always there, so if you don't get a response straight away please try again later. 
Assignee: alex → general

Comment 2

11 years ago
Is this bug still "true"?
The url unfortunately can't be accessed now, which makes it a bit obscure without the source...
Created attachment 250633 [details]
binding for testcase
Created attachment 250635 [details]
binding for testcase
Attachment #250633 - Attachment is obsolete: true
Created attachment 250636 [details]
CSS for testcase
Attachment #250634 - Attachment is obsolete: true
Created attachment 250637 [details]
testcase - rectangle in XUL namespace
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.