Status

()

RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: moz, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 Windows98 Firefox/0.9

I wanted to apply SK localization pack 0.8 to Firefox 0.9 since localization for
0.9 dosen't exist yet. I opened the file in browser, allowed installation, and
the installation seemed to completed. Installer then adviced in SK language,
that I should run firefox from commandline with
-UILocale sk-SK -contentLocale SK
parameters. This is totaly inconvenient, and for amateur user impossible either.
It was nor easey for me to figure out, how the ""s must be structured in
C:\Program Files\Mozilla Firefox   etc.. to allow parameter adition.

The localization dosen't function even with the parameter.

Reproducible: Always
Steps to Reproduce:
1.try to localize the installed english Firefox 0.9 to SK language.
2.
3.

Actual Results:  
Applying 0.8 language pack to Firefox 0.9 completed without notion that it is
undesirable or impossible.
Installer then demands user to write long parameter to commandline both with the
Firefox full path. Do we live in 1980's?
Even after doing it, no localization effects.

Expected Results:  
1, If language pack is not to work, the Firefox must clearly state it.
2, Language pack from older version SHOULD function on newer version of the
program, even at the price of some strings remaining untranslated
3, Instalator must not demand user to do any magic with command line since the
Firefox looks very amateurish doing so
4, User should be able to set the localization with full comfort in Preferences
(Options in W$) selecting the desired language.

If it is possible to make functional localization pack for Mozilla, why it is
such a problem for Firefox?
(Reporter)

Comment 1

15 years ago
Let me say that it's only localization that sucks for me. The whole installation
of Firefox was great, including import of settings from IE or Mozilla. Very
nice, I wonder why Mozilla dosen't do these things so nicely too.
well, you can't apply a 0.8 languagepack to 0.9. It just does not work. 
Furthermore, the whole procedure has changed now, it is possible to install a
languagepack in Firefox 0.9.x *without* the commandline switch. (as seen in the
German languagepack)

Marking invalid, as I said: you can't use a 0.8-LP for 0.9.x
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.