FireFox 'always' returns: "Error: No running window found" on "./firefox -remote 'ping()'" and "./firefox -remote 'openURL()'"

RESOLVED DUPLICATE of bug 246166

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED DUPLICATE of bug 246166
14 years ago
10 years ago

People

(Reporter: James Baker, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Even when there is another FireFox window open, a -remote command always
returns: "Error: No running window found" on commands such as "./firefox -remote
'ping()'" and "./firefox -remote 'openURL()'".  

Reproducible: Always
Steps to Reproduce:
1. Start firefox
2. enter the command: $FIREFOX_DIR/firefox -remote
'openURL('http://www.mozilla.org', new-window)' ($FIREFOX_DIR = directory where
firefox is installed)


Actual Results:  
1. First Firefox window opened.
2. Returned: "Error: No running window found"

Expected Results:  
1. First Firefox window open.
2. Open www.mozilla.org in a new window. 

I am using Suse Linux 9.1 on a P4, using the
firefox-0.9-i686-linux-gtk2+xft-installer.tar.gz download.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 246166 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.