improper sorting by flag, label etc.

RESOLVED DUPLICATE of bug 238631

Status

RESOLVED DUPLICATE of bug 238631
15 years ago
13 years ago

People

(Reporter: thingol, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: version 0.7 (20040616)

When using message sorting by Status, Flag, Label or Priority, empty values are
treated as ascendant ones, so ascending sort places empty labelled message below
any labelled, and so on. Under typical conditions, where flagged or labelled
messages are rather interesting to see in very large bunch of other messages, it
causes inconvenience beacuse of necessity to scroll up to top of message list. 

The same things, but with reversed direction, are happens to descending sorting.
Labelled messages appear in bottom, but non-labelled messages are sorted by
order received descending.

Reproducible: Always
Steps to Reproduce:
1. Mark any email as flagged.
2. Sort by flag.


Actual Results:  
Flagged messages placed near oldest unflagged messages.

Expected Results:  
Flagged messages should be placed near newest unflagged messages.
(Reporter)

Comment 1

14 years ago
Scott, please, take a look on this bug.

Comment 2

14 years ago
The fix for this goes in the backend.


*** This bug has been marked as a duplicate of 238631 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.