Displays maxVer 0.9 themes/extensions for FX 0.9.0+/0.9.1+

RESOLVED FIXED

Status

defect
P2
major
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: steffen.wilberg, Assigned: wolf)

Tracking

Details

(Whiteboard: fixed-development)

Reporter

Description

15 years ago
Ben changed the version of Firefox to 0.9.0+ today.
But u.m.o still displays extensions and themes which specify a maxVersion of
0.9, e.g. All-in-One Gestures extension and the Charamel theme.

This causes all sorts of weird errors in Firefox (extension is downloaded, but
not correctly installed, disabling it breaks your profile).

I already posted a message in the extensions and themes forums on mozillazine.

Updated

15 years ago
Summary: umo displays extensions and themes with maxVersion=0.9 for my 0.9.0+ Firefox → Displays incompatible themes

Updated

15 years ago
Summary: Displays incompatible themes → Displays maxVer 0.9 themes/extensions for FX 0.9.0+
Reporter

Comment 1

15 years ago
Firefox 0.9.1 will be released in a few days:
http://forums.mozillazine.org/viewtopic.php?t=90193

This bug will affect users of that release. It's no longer limited to nightly
build users.
OS: Windows XP → All
Hardware: PC → All
Summary: Displays maxVer 0.9 themes/extensions for FX 0.9.0+ → Displays maxVer 0.9 themes/extensions for FX 0.9.0+/0.9.1
Assignee

Updated

15 years ago
Assignee: nobody → psychoticwolf
Assignee

Comment 2

15 years ago
0.9.1 is 0.9 for extension/theme purposes. and at the moment, 0.9 is correctly
shown for 0.9.1.. this might be a little misleading for end-users though. (I
have a feeling if a newer version was max on the site, 0.9.1 would suddenly snap
to it though.

0.9+ branch and trunk users are affected by this bug, but it's not critical as
it's no different than what you're used to during a development cycle. random
extension bustage. heh.

Severity: critical → major

Comment 3

15 years ago
Is this why 0.9.1 gives me an 'Updates are available' message every time I
launch the browser? It tells me that un update to 0.9.1 is available though I'm
already running 0.9.1.
Assignee

Comment 4

15 years ago
(In reply to comment #3)
> Is this why 0.9.1 gives me an 'Updates are available' message every time I
> launch the browser?

No, that's Bug 249015. This is about the website listings themselves.
Assignee

Updated

15 years ago
Priority: -- → P2
Assignee

Comment 5

15 years ago
By default, Firefox will allow 0.9 extensions to be installed in nightlies, now.
but, as this bug points out, its not a good idea to be showing 0.9 extensions to
0.9+/0.9.1+ users by default. This is now fixed in the development version of
update. Of course, advanced users can select "Firefox 0.9" as the version they
want to see listings for, and install anything from that list.

Also, update now treats all 0.9.x branch users (0.9.0- 0.9.3) as 0.9 itself,
which is how it's supposed to be, to match the EM version. This should fix the
need for authors to put maxVers like 0.9.3 which are technically, incorrect and
unneeded updating.
Status: NEW → ASSIGNED
Summary: Displays maxVer 0.9 themes/extensions for FX 0.9.0+/0.9.1 → Displays maxVer 0.9 themes/extensions for FX 0.9.0+/0.9.1+
Whiteboard: fixed-development
Assignee

Comment 6

15 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Assignee

Updated

15 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.