If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Profile manager states no backwards compatibility after profile conversion

VERIFIED FIXED in M14

Status

SeaMonkey
Startup & Profiles
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: simone, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
Using the 1/21 build on Win32. The profile manager asks me to select a profile 
to convert, and states that I will no longer be able to use the profile with the 
product that created it. Since JAR wants us to flag things that would make us 
unable to use the product, I'm entering this bug. This backwards incompatiblity 
would completely keep me from using the product for my daily work! If the build 
crashes and I'm forced to reinstall, I don't want to have to recreate another 
profile in 4.x. (I tried assigning this bug to Ben Goodger but Bugzilla tells me 
he doesn't have an account)
seth reckons that they actually do allow backwards compatibility, meaning this 
text is a lie. I'll reconfirm with him and change the text when i do these 
dialogs. otherwise I'll mark this a back end issue. 
Status: NEW → ASSIGNED

Comment 2

18 years ago
m14 radar, dogfood

Summary: Profile manager states no backwards compatibility after profile conversion → [DOGFOOD] Profile manager states no backwards compatibility after profile conversion
Target Milestone: M14

Comment 3

18 years ago
This is mis-leading text.  This should not say "backwards compatibility". 
Putting on PDT-, not blocking beta1.  ccing selmer

rudman, can we get this reworded?
Assignee: ben → rudman
Status: ASSIGNED → NEW

Comment 4

18 years ago
For the beta, we still have a copy and diverge migration.  Therefore, this text 
is actually misleading at this time.  AFTER the beta, it should be changed when 
we finish migration in place.  Should Ben@netscape.com own this after all?

Comment 5

18 years ago
Putting on PDT+ radar for beta1.
Keywords: beta1
Summary: [DOGFOOD] Profile manager states no backwards compatibility after profile conversion → Profile manager states no backwards compatibility after profile conversion
Whiteboard: [PDT+]

Comment 6

18 years ago
*** Bug 25494 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
sspitzer has clarified this problem for me... that the dialog doesn't actually
reflect reality. It's still keeping people from using it for daily work. I know
that i certainly don't want my 4.x preferences blown away by trying a new build.
Especially since there is no ui to add message filters in 5.0 yet.

How hard is it to change the dialog text so that people will use windows for
dogfood?

Comment 8

18 years ago
It's not hard to suggest new text...but presumably you (or Ben?) will make the 
actual changes.

Reassigning to Vera for wording. Seems like we just need to tell people that 
files are being copied into a new profile (leaving existing profiles intact).
Assignee: rudman → verah

Comment 9

18 years ago
Accepting, but I'm not seeing the offending wording anymore. Was it revised? If 
so, was it revised for M13 or later? (I haven't been able to download the M13 
build for the past couple of days.)
Status: NEW → ASSIGNED

Comment 10

18 years ago
Ben,

This is the bug we discussed earlier today-fyi.

Comment 11

18 years ago
I touched up the UI text and handed marked-up hard copy off to Ben. Re-assigning
to Ben.
Assignee: verah → ben
Status: ASSIGNED → NEW
wording changes checked in. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 13

18 years ago
build 2000021109
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.