u.m.o/update.rdf: file not found

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED FIXED
14 years ago
2 years ago

People

(Reporter: Steffen Wilberg, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
The url http://update.mozilla.org/update.rdf is specified by the pref
"update.app.url" for the Software Update of Firefox.

But opening this file results in an 404 Not Found error. Firefox displays a (way
too generic) error messages when clicking on "Update" in the extensions manager
because of that.

Maybe we can upload a dummy file until we have a proper feed?

Comment 1

14 years ago
I tried having a blank file there (to stop the apache error_log from filling
with 404s), but I suspect it may be the cause of the recent firefox crashes WRT
update.

I do need to know what's supposed to happen with this file though. Going to
attempt to find out from Ben.

Comment 2

14 years ago
Um, Ben's webservice isn't running on port 80, so I think this default needs to
change.  
Component: Update → Extension/Theme Manager
Product: mozilla.org → Firefox
Target Milestone: --- → Firefox1.0beta
Version: other → unspecified
(Reporter)

Comment 3

14 years ago
alanjstr, you don't happen to know the right port? Or is the webservice not
running yet?

Comment 4

14 years ago
Last I saw it was 8080, with some weird path.
(Reporter)

Comment 7

14 years ago
Created attachment 151067 [details]
update.rdf for Firefox 0.9

This is taken from the "goat" version, but it's for Firefox 0.9 instead of 1.2.
It has to be served as text/rdf, as Ben explains in his doc:
http://www.bengoodger.com/software/mb/extensions/packaging/extensions.html

It's also available on http://www.steffen-wilberg.de/update.rdf (as text/rdf)
right now. If you want to try it, set the pref "update.app.url" to that
location.

The benefit is that Software Update doesn't time out and the u.m.o server log
isn't filled with 404s. Beware, an empty file served as text/rdf crashes
Firefox.

Comment 8

14 years ago
(In reply to comment #7)
> Created an attachment (id=151067)
> The benefit is that Software Update doesn't time out and the u.m.o server log
> isn't filled with 404s. Beware, an empty file served as text/rdf crashes
> Firefox.
heh, the UMO error log is 140mb ;-) already... I tried an empty text/rdf file
already to stop that, unaware it caused a crash. (whoops)

Reassigning to the right owners for this component, instead of update. (Always
Reassign to default when moving. :-) )

Does this file need to posted on update?
Assignee: nobody → bugs
QA Contact: mozilla.update → bugs
(Reporter)

Comment 9

14 years ago
> Does this file need to posted on update?
Yes, to http://update.mozilla.org/update.rdf.

Make sure it is served as text/rdf. Adding "AddType text/rdf;charset=UTF-8 .rdf"
to the .htaccess file should do the trick.
(Reporter)

Comment 10

14 years ago
Let's toss this bug around a bit...
Component: Extension/Theme Manager → Software Update
(Reporter)

Comment 11

14 years ago
...back to mozilla.org/update...
Assignee: bugs → nobody
Component: Software Update → Update
Product: Firefox → mozilla.org
QA Contact: bugs → mozilla.update
Target Milestone: Firefox1.0beta → ---
Version: unspecified → other
(Reporter)

Comment 12

14 years ago
...and marking fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 13

14 years ago
How is this not a bug in the application if it points to a bogus URL?

Comment 14

14 years ago
The URL was only bogus because the file was missing from the server. That was
solved by putting the right file on the server, which makes it a server-side issue.

Comment 15

14 years ago
Ok, so Firefox is going to call update.rdf, which does nothing.  Unless we do
browser sniffing to redirect it to a update.php?firefox or some such.  In which
case, that forces us to detect what application is calling the url instead of
the application telling us what it needs.  

I think we're trying to solve this "problem" from the wrong way.  Fix the
application to point to the right url, instead of making the website cope.
(Reporter)

Comment 16

14 years ago
Who says the file does nothing? It tells Software Update that version 0.9 of
Firefox is the recent version. Other products, like Thunderbird, and localized
products can be added to that file as additional RDF entries. No need to do
browser sniffing.
(Reporter)

Comment 17

14 years ago
I forgot to add that the file itself provides the necessary link. The url for
the product Firefox, version 0.9, is http://www.mozilla.org/products/firefox/.

Comment 18

14 years ago
So it can have multiple RDF:Descriptions?  If so, then ok.

Comment 19

14 years ago
Update.rdf is the smartupdate datasource... I know it works properly for Firefox
because I tested it. :-)

This is not an application bug, it belongs in update.
You'd have to ask Ben if it can support multiple RDF:Descriptions or not.. my
understanding is it can. Though the current one doesn't include the data for
Thunderbird. Hopefully by the time Tbird hits 0.8, mscott or ben will provide that.

Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.