mouseout event won't fire when mouse moves out from div into iframe

RESOLVED DUPLICATE of bug 164302

Status

()

RESOLVED DUPLICATE of bug 164302
14 years ago
5 years ago

People

(Reporter: m_yangxin, Unassigned)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040316, and Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9, and Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

the provided test page has two DIV tags absolutely positioned inside an IFRAME 
area, both DIV tags have onmouseover/onmouseout events set up to change 
background color.

the mouseover event is fired correctly, while the mouseout event is fired only 
when the mouse moves into the other DIV tag or out off the IFRAME border.


Reproducible: Always
Steps to Reproduce:
1. load the test page
2. mouseover one DIV, background color changes
3. mouseout to IFRAME area (grey), nothing happens (no mouseout event fired)
4. mouseover another DIV or mouseout the IFRAME area, first DIV background 
color restores (mouseout event fires now)
Created attachment 162565 [details]
uploaded testpage: dummy iframe content

For preserving the testcase, I uploaded the page.
Dummy.html (iframe content)
Created attachment 162566 [details]
Testcase (same as in URL)

Uploaded the testcase to preserve the document.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

I see this too.

The mouseover event triggers *always* when entering a DIV (blue square).
The mouseout event triggers *only* when leaving the iframe (grey area), either
by moving over the DIVs or out of the iframe area.
I think bug #262194 is a duplicate of this one.

Anybody with enough "access rights", could you please double check and if
confirmed, mark the other bug as duplicate. Thanks.
Bug #155276 does the same with the IMG element but is (currently) lacking a
testcase.

Comment 6

14 years ago
Do we have an update on this? 

This bug seems to be getting more attention from our users.

Another test case can be seen at http://www.milonic.com/bugreports/mozbug2.php

Cheers,
Andy

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 164302 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.