firefox 0.9.x doesn't start up as user if no write-access to installation-dir

RESOLVED DUPLICATE of bug 246789

Status

()

RESOLVED DUPLICATE of bug 246789
15 years ago
14 years ago

People

(Reporter: wolfiR, Assigned: bryner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040618
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040618

I built my own firefox under Linux with almost the same build-config as original
firefox builds. But only the profile-migrator does start. Firefox doesn't start
up afterwards.
startup output will be attached.

Reproducible: Always
Steps to Reproduce:
.
(Reporter)

Comment 1

15 years ago
Created attachment 151080 [details]
startup-output

Comment 2

15 years ago
I'm getting the same thing, too.  My mozillaconfig is here:

http://cablespeed.com/~tygris/mozconfig.txt

For getting the output, I've switched on --enable-debug, --disable-optimisation,
and removed stripping. The output of firefox via: (firefox 2>&1) > bug.txt

http://cablespeed.com/~tygris/bug.txt

Comment 3

15 years ago
Created attachment 151225 [details]
tygris .mozconfig

Comment 4

15 years ago
Created attachment 151227 [details]
tygris output from firefox debug

Comment 5

15 years ago
http://www.mozilla.org/products/firefox/releases/0.9.html#issues

"If Firefox 0.9 is placed in a location with limited access privileges, it
should be run by a user with access to that location first, so that all initial
startup files are generated. There may be issues still where if a
restricted-access user is the first to run the app, these files may not be
generated properly and Firefox may enter an infinite restart loop. This will be
fixed in a future release."

sudo firefox or (temporarily) chown everything to resolve.  Now why does it need
to do that?

Comment 6

15 years ago
That did it.  Thanks.
(Reporter)

Comment 7

15 years ago
I've thought that "firefox -register" is for that purpose and that was running
definitely before.
(Reporter)

Comment 8

15 years ago
I can confirm that it works if I start it as root first.
But this is not a real option for us.
As firefox -register is run as root after installation this call has to fix
those things if needed.
(Reporter)

Updated

15 years ago
Summary: own firefox 0.9 build doesn't start up after import → own firefox 0.9 build doesn't start up as user

Comment 9

14 years ago
Under RHEL3 WS update 2, when I install firefox 0.9.1 from: 
 
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.9.1/firefox-0.9.1-i686-linux-gtk2+xft.tar.gz 
 
and then: 
 
    cd /var/tmp; tar -xzvf firefox-0.9.1-i686-linux-gtk2+xft-installer.tar.gz 
    cd /var/tmp/firefox-installer; ./firefox-installer 
 
    <<standard install of firefox, as root, under /usr/lib/firefox-0.9.1>> 
 
firefox starts up as root just fine.  However If I start firefox as a non-root 
user, firefox hangs printing the following message: 
 
	*** loading the extensions datasource 
	*** loading the extensions datasource 
	*** loading the extensions datasource 
	... 
 
Now if I do the following: 
 
	chown -R username /usr/lib/firefox-0.9.1/extensions 
 
	<<run firefox as username>> 
 
	chown -R root /usr/lib/firefox-0.9.1/extensions 
 
then the non-root user can run firefox without any problems. 
All that is needed is for firefox to run once where the non-root 
user owns the extensions.  Then you can chown it back to root 
and everything runs fine from then on. 
 
It is interesting that the following RPM: 
 
	firefox-0.9.1-0.fdr.3.i386.rpm 
 
from one of the mirrors listed on: 
 
http://rpm.pbone.net/index.php3/stat/4/idpl/1330817/com/firefox-0.9.1-0.fdr.3.i386.rpm.html 
 
will install firefox in such a way as to not need the chown hack. 
To test firefox using this rpm, first: 
 
	rm -rf /usr/lib/firefox-0.9.1 
 
and then: 
 
	rpm -ivh firefox-0.9.1-0.fdr.3.i386.rpm.html 
 
What is that rpm doing right, that the firefox installed doesn't do??? 
 
(Reporter)

Comment 10

14 years ago
Ben confirmed that bug in personal mail. This is a no-go for preinstallation
with RPM packages. Slightly changed the summary to be more descriptive.
Summary: own firefox 0.9 build doesn't start up as user → firefox 0.9.x doesn't start up as user if no write-access to installation-dir
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0RC1?

Comment 11

14 years ago
This has been fixed.

*** This bug has been marked as a duplicate of 246789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Flags: blocking-aviary1.0PR?
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.