If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HTTP redirect for remote calendar fails as error

VERIFIED DUPLICATE of bug 247490

Status

Calendar
General
VERIFIED DUPLICATE of bug 247490
13 years ago
11 years ago

People

(Reporter: Malte Starostik, Assigned: Mostafa Hosseini)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

Above URL is a HTTP 301 redirect to the German Holidays file provided on your
site. I wanted to use such a setup to make the URL appear "local" for several
reasons.
When specifying such a redirected URL for a remote calendar, Sunbird barfs at it
as an "error" 301 instead of following the redirection.

Reproducible: Always
Steps to Reproduce:
1. Subscribe to the calendar at http://malte.homeip.net/holidays.ics
2. Refresh remote calendars
3.

Actual Results:  
No events from the subscribed resource are displayed, instead the HTTP 301
redirect is handled as an error condition.

Expected Results:  
The redirect should have been transparently followed.
bug 247490 is slightly newer, but has a patch and all, so marking as dup.

*** This bug has been marked as a duplicate of 247490 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.