For some reply pages in Livejournal Firefox hangs

VERIFIED DUPLICATE of bug 241906

Status

()

--
critical
VERIFIED DUPLICATE of bug 241906
15 years ago
7 years ago

People

(Reporter: simon.lucy, Assigned: bugzilla)

Tracking

({hang, perf})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

The hang is either a block or infinite loop.  No other processes are affected. 
This is very similar in description to
http://bugzilla.mozilla.org/show_bug.cgi?id=241906


Reproducible: Always
Steps to Reproduce:
1. Find journal on Livejournal
2. Click 'Comment' or whatever button to launch reply page
3. On around 8 out of 10 reply pages Firefox will 'hang'

Actual Results:  
Hang

Expected Results:  
Ummm, not hang.

Updated

15 years ago
Keywords: hang
Summary: For some reply pages in Livejournal Firefox 'hangs' → For some reply pages in Livejournal Firefox hangs

Comment 1

15 years ago
I can confirm this.  Firefox 0.9 hangs and eats 100% CPU until I kill it. 
Always reproducable.  Very annoying, and is a regression new to 0.9 (was using
0.8 milestone).

Comment 2

15 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040622
Firefox/0.8.0+ (trunk)
(Reporter)

Comment 3

15 years ago
(In reply to comment #2)
> WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040622
> Firefox/0.8.0+ (trunk)

So this is a later build on XP.

Comment 5

15 years ago
confirmed for me with 0.9.1 nightly 6/26 (though why does it say 0.8 in the
browser string? that's a separate bug) on win2k

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.8
(Reporter)

Comment 6

15 years ago
Can this at least get a NEW for Windows 2000?
It may well be fine in XP, its certainly not in Win2K.

Comment 7

15 years ago
Just now upgraded to 0.9.1 -- the bug still exists, alas. I am using Win XP.
(Reporter)

Updated

15 years ago
Keywords: perf

Comment 8

15 years ago
Confirmed to me both in Firefox 0.9 and Firefox 0.9.1. It never hangs on any
other pages to me.

I'm using XP. 

Comment 9

15 years ago
This error also affects me and occurs every time i attempt to make a comment. I
have tested it under Windows XP Professional and Windows XP 64-Bit for 64-Bit
Extended Systems Beta.

I am inclined to believe it has something to do with forms.

Comment 10

15 years ago
I've had this happen to me too.  Although in my case, I successfully loaded a
comment page using my active tab, but when I tried to open it in a background
tab using middle click, it went to 100% cpu utilization and froze.  On Windows.
 Build 20040707.  Had upgraded from Firefox 8 today.  Adblock is installed.
(Reporter)

Comment 11

15 years ago
Just tried it with the 0.9.2 update, still the same.  I had another site hang,
http://www.novatech.co.uk in their checkout forms.  As it was in the middle of a
transaction it wasn't pleasant.

Comment 12

15 years ago

*** This bug has been marked as a duplicate of 241906 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 13

15 years ago
If you're going to mark things as duplicate, then at least first acertain that
they are duplicate.

http://bugzilla.mozilla.org/show_bug.cgi?id=241906 is referenced by this bug,
241096 is solely on Linux, this is on Win2K and XP.  They may be the same cause,
they may be not.

Additionally, 241096 has a status of UNCONFIRMED, this had a status of NEW, if
you don't understand the difference you shouldn't have the privilege of changing
the status.  This is exactly the way bugs do NOT get fixed.

Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 14

15 years ago
Just to second -- 0.9.2 still has the problem. Although, every once in a while
it doesn't. My room mate opens the comments page in a new tab and says that
works for her, but it only works about a thrid of the time for me. I use the
"open in IE" extension as a workaround.

I have yet to find another website that does this.
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040717
Firefox/0.9.1+

Can someone who experiences the bug try to create a minimized testcase?  Start
ripping out HTML until you have the minimum required to hang the browser?

Comment 16

15 years ago
(In reply to comment #15)
> Can someone who experiences the bug try to create a minimized testcase?  Start
> ripping out HTML until you have the minimum required to hang the browser?

No such HTML. When I save the page with IE then load it in Firefox, it works fine.
(Reporter)

Comment 17

15 years ago
Using the workaround on http://bugzilla.mozilla.org/show_bug.cgi?id=241906 seems
to fix it for me.

Essentially, delete the password entries for www.livejournal.com in the .s file
in the Application Data\Mozilla\Firefox tree.  The entries look very nasty anyhow.

Delete from the www.livejournal.com line to the . so that it follows on.

If someone else can verify that it works for them and that it didn't before then
I'll mark it fixed.
a(In reply to comment #13)
> If you're going to mark things as duplicate, then at least first acertain that
> they are duplicate.
> 
> http://bugzilla.mozilla.org/show_bug.cgi?id=241906 is referenced by this bug,
> 241096 is solely on Linux, this is on Win2K and XP.  They may be the same cause,
> they may be not.
> 
> Additionally, 241096 has a status of UNCONFIRMED, this had a status of NEW, if
> you don't understand the difference you shouldn't have the privilege of changing
> the status.  This is exactly the way bugs do NOT get fixed.
> 
> Reopening.

re-duping.  If you don't know that this code cross-platform and has pretty much
zero difference between platforms, you should ask before slagging others.

*** This bug has been marked as a duplicate of 241906 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 19

15 years ago
I'm well aware of the nature of this codebase, and not everything does affect
different platforms.  

My main gripe was that you set a bug with status of new as duplicate of
something that was unconfirmed.  In other words before messing with bug reports,
read and understand them.  I don't raise bugs lightly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.