Firefox 0.9 crashes immediately upon execution

RESOLVED DUPLICATE of bug 247284

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 247284
14 years ago
14 years ago

People

(Reporter: Keith Montgomery, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Installed Firefox 0.9 on my Win XP Home version machine;

Firefox worked OK for a day or so;

Inexplicably, it now crashes immediately on startup whenever I attempt to run it;

It appears to be trying to post a dialog box when it crashes. Could this be the
"Change Default Browser" message box?

I uninstalled and then reinstalled Firefox into a clean folder, makes no difference;

This problem is consistently reproducible on this machine. HOWEVER, I am also
successfully running Firefox on two different machines, both using Win XP Pro,
and neither of these machines manifests this problem;

MS IE6 is my default browser, with Outlook express as the default email app.

I have PanicWare's "Pop-up Stopper" utility in use (free version, 3.0.1008).

Norton Anti-virus is also running.

I also installed Mozilla 1.6 on the problematic machine, and Mozilla DOES NOT
show the same problem as Firefox.


Reproducible: Always
Steps to Reproduce:
1. Install Firefox 0.9
2. Use Firefox to browse immediately after installing it, and then wait one day,
or so (not joking)
3. On the next startup, Firefox crashes while attempting to post some sort of
dialog box.

Actual Results:  
KABOOM!

The main Firefox window appears, with menus and toolbar(s), and then it attempts
to post this mysterious dialog box. 

Then the Windows "Application Crashed" dialog box comes up, prompting me to
submit an error report to Microsoft.

Expected Results:  
Not crashed !?

No info available.

Please, PLEASE, PLEASE! fix this problem. I am investigating using non-MS
browsers as a way of avoiding spyware and other forms of mal-ware. Firefox looks
like it could be the one.

Comment 1

14 years ago
Can you please check if the work-around in bug 247284, comment 16 helps?

Report back here, thanks

Comment 2

14 years ago
Bug 247455 may have something similar, if for Linux.

Comment 3

14 years ago
Bug 247284 seems very similar and has more information, including a workaround.

*** This bug has been marked as a duplicate of 247284 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.