Firefox 0.8 not removed after installing 0.9

VERIFIED INVALID

Status

()

Firefox
Installer
VERIFIED INVALID
14 years ago
12 years ago

People

(Reporter: x10, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

I had Firefox 0.8, then installed 0.9. In the "add or remove programs" screen,
both versions are present. When I try to uninstall 0.8, I get an error about a
log file that can't be found and a registry key.

btw, I tried to reproduce the error so I could type it literally here, and in
the process the uninstaller closed this bugzilla page without asking me.

Reproducible: Always
Steps to Reproduce:
1. install Firefox (0.8)
2. install new version (0.9)
3. go to control panel "add and remove programs"
4. try to uninstall older version.

Actual Results:  
got an error box, old version still present in add/remove programs dialog screen.

Expected Results:  
1. version 0.8 (or old version in general) should not have been there in the
first place, after installing 0.9.
2. it should have uninstalled properly.

Comment 1

14 years ago
The release notes for 0.9 specifically say:
"First, for these preview releases it is strongly recommended that you uninstall
any previous version of Firefox first. Installing over the top of an older
version may cause unpredictable problems. If you install over the top of an
older version and want to file bugs, please do a clean install into a fresh
directory before doing so"

So, you can't expect it to work when you've already been told it's probably not
going to....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Thanks for the friendly comment. I don't "expect it to work", I just reported
something that doesn't work that should work in the final release.

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.