Downloading a file with the same name as one already downloading kills first download

RESOLVED DUPLICATE of bug 236514

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 236514
14 years ago
9 years ago

People

(Reporter: David Balažic, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

FF 0.9RC

Download a file ( a large one, so it takes a while ).
Download another file ( form another site ), but one that has the same name.

In both cases select "Save to Disk".

Result : When the second download starts, the first one is killed and removed
from the DL manager.

Expected results : Both downloads finish, one having a changed name ( -1
appended or something )

I used these two URLs:
http://zeniiia.linux.org.uk/pub/distributions/fedora/linux/core/updates/2/i386/kernel-sourcecode-2.6.6-1.435.noarch.rpm
http://ftp.surfnet.nl/ftp/pub/os/Linux/distr/fedora/updates/2/i386/kernel-sourcecode-2.6.6-1.435.noarch.rpm

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
PS: When I cancel the second download and clean up the DL manager, its window
title still says "18% 1 of 2" ( or similar, it just crashed and I did not
remember the exact string )

Comment 2

14 years ago
This may or may not be a dup of Seamonkey bug 157548 about the same issue.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 236514 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.