Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 242207
13 years ago
9 years ago

People

(Reporter: Ng Ming Hong, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Firefox 0.9 keeps losing the history regularly. When the history is lost, I
can't auto-complete the frequently/recently visited URLs in the location bar. I
clicked Ctrl + H and it onlys display several sites I visited today (i.e. only
have the "Today" folder).

For the setting for history, I'm using the setting value: Remember visited site
for 20 days. I use Firefox everyday, so it is unlikely to be caused by aging of
history.

I didn't use Mozilla 1.7, so I'm not sure if this bug belongs to Mozilla too.

Reproducible: Sometimes
Steps to Reproduce:
1. (Not sure) Startup Firefox when a new day has started (00:00).
Actual Results:  
Almost all the history are lost.

Expected Results:  
It should only remove the history if and only if it isn't used for N days (e.g.
20 days) or more.

Comment 1

13 years ago
> Firefox 0.9 keeps losing the history regularly. When the history is lost, I
> can't auto-complete the frequently/recently visited URLs in the location bar.

I have the same problem with FF 1.0 PR. The history seems to be emptied from
time to time, sometimes even more than once a day!
Bug 102519?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Bug 102519?

That bug is much much older... But this bug starts since Firefox 0.9x only...

*** This bug has been marked as a duplicate of 242207 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> 
> *** This bug has been marked as a duplicate of 242207 ***

Are you sure? Because it doesn't happen it Netscape, Mozilla, and older versions
of Firefox.
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > 
> > *** This bug has been marked as a duplicate of 242207 ***
> 
> Are you sure? Because it doesn't happen it Netscape, Mozilla, and older versions
> of Firefox.

Sorry, my mistake. It IS duplicate of bug 242207. But bug 242207 is NOT a
duplicate of bug 102519.

Updated

9 years ago
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.