Browser doesn't see CSS class name's like 2 or 3 but see 2a or 3a

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: fxart, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

Browser doesn't see CSS name's like 2 or 3 but see 2a or 3a. This situation is
where we're trying to use span class or td class name like 
<span class="2">Some text</span> // N O T    F O R M A T E D   T E X T 
<span class="a2">Some text</span> // O K
<span class="2a">Some text</span> // N O T    F O R M A T E D   T E X T 
Very strange huh ?? ;)

Reproducible: Always
Steps to Reproduce:
1.Change name my style class from 2 to 2a
2.
3.

Actual Results:  
Everything is ok

Expected Results:  
Fixed I gues ;)

No information

Comment 1

15 years ago
It's not strange at all.  Class names are not allowed to start with a digit.
http://www.w3.org/TR/CSS21/syndata.html#q6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
*** Bug 277317 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.