FireFox dosn't remove old version numbers from Add/Remove Programs

VERIFIED DUPLICATE of bug 247884

Status

()

Firefox
Installer
--
major
VERIFIED DUPLICATE of bug 247884
14 years ago
12 years ago

People

(Reporter: Robin Monks, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When installing a new version of FF the old version number is still displayed in
Add/Remove Programs in the control panel.

This happen for me when I went from Nightlies to RC1 then from RC1 to 0.9

Reproducible: Always
Steps to Reproduce:
1.install an old firefox nightly
2.intall the new 0.9
3.look in add/remove programs in you control panel

Actual Results:  
Both of the versions show in add/remove programs

Expected Results:  
Removed the old version info from add/remove first, then upgraded.

I believe this could cause trouble in the future with Windows XP and if
continued could place many firefox's in add/remove

Comment 1

14 years ago
Thunderbird behaves the same way.
you need to uninstall the old version first.  Uninstallation of previous
versions is planned but not implemented, see the release notes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 247884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.