Closed Bug 24771 Opened 20 years ago Closed 20 years ago

Changing the background color dynamically generates a table border when the tables border is set to "0"

Categories

(Core :: Layout: Tables, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 25425

People

(Reporter: ngreen, Assigned: karnaze)

References

()

Details

For a given HTML table, if you place an onMouseOver/onMouseOut event handler 
set to dynamically swap out the background color using the following syntax:

     onmouseover="this.style.backgroundColor='#ff0000'"
     onmouseout="this.style.backgroundColor='#ffffff'"

and (it seemes, only if) there is a border attribute present that is set to "0" 
as follows:

     <table border="0">

A table border will be generated.  A sample of this is at the URL below:

http://www.neilsmachine.com/bug.html

I'm using Windows NT, Service pack 5 and am using Milestone 12.  The build ID 
in the lower right hand corner of the browser is 1999122023.
I don't see this problem on Win98 2000021108.
Can the reporter of this bug verify this?
I also don't see the problem on Linux 02/11/00 CVS build.

*** This bug has been marked as a duplicate of 25425 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified dup of #25425 which has been fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.