crash if I try to insert a line into a reply mail

RESOLVED DUPLICATE of bug 243809

Status

MailNews Core
Composition
--
critical
RESOLVED DUPLICATE of bug 243809
14 years ago
10 years ago

People

(Reporter: cityhunter, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a1) Gecko/20040617
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a1) Gecko/20040617

when I try to insert a line into a reply (making per paragraph reply) mozilla crash


Reproducible: Always
Steps to Reproduce:
1.press reply to
2.go inside quoted mail
3.press enter

Actual Results:  
whole mozilla crash, the windows simply desapear from screen

Expected Results:  
as usual : split the quoted message so I can reply ^_^

Comment 1

14 years ago
can you post Talkback Incident ID for this crash
"mozilla/components/talkback/talkback" ?
related: bug 199708.
Keywords: crash, stackwanted
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> can you post Talkback Incident ID for this crash
> "mozilla/components/talkback/talkback" ?
> related: bug 199708.

yes if you give me the method to make a talkback
if you want i can produce a coredump.... but attaching a 21+Mo file isn't a good
thing 

Comment 3

14 years ago
I assume you're using a mozilla.org build which should have Talkback included
http://www.mozilla.org/quality/qfa.html, you can check if Talkback is here by
checking if you have "mozilla/components/talkback/talkback".

If I'm wrong :) and you built your own build with --enable-debug, then can you
attach the stacktrace ?
Start Mozilla with "mozilla -g"
"GDB> run"
When Mozilla crashes and you go back to console:
"GDB> bt" attach the output of bt (backtrace) via "create a new file attachment"

Comment 4

14 years ago
Reporter: Are you building your own Mozilla builds, and is that where you see
the crash? If yes: Please confirm actual build ID (timestamp of last CVS pull).
Asking because if this is reported with a local build, the build ID is bogus.
This resembles topcrash bug 243809
(Reporter)

Comment 5

14 years ago
I had finaly enough time to recompile mozilla in debug mode

here is the backtrace :
.h, line 711
Break: at file ../../../dist/include/xpcom/nsCOMPtr.h, line 711

Program /usr/lib/mozilla-1.8a1/mozilla-bin (pid = 27861) received signal 11.
Stack:
_ZN13nsProfileLock18FatalSignalHandlerEi+0x0000005F
[/usr/lib/mozilla-1.8a1/components/libprofile.so +0x0002DA5F]
UNKNOWN [/lib/libpthread.so.0 +0x0000B603]
UNKNOWN [/lib/libc.so.6 +0x00028D98]
_ZN12nsHTMLEditor18EndUpdateViewBatchEv+0x000000BA
[/usr/lib/mozilla-1.8a1/components/libeditor.so +0x00096AFA]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libeditor.so +0x0011FA24]
_ZN22nsAutoPlaceHolderBatchD1Ev+0x00000049
[/usr/lib/mozilla-1.8a1/components/libeditor.so +0x0009E389]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libeditor.so +0x00082388]
_ZN12nsHTMLEditor14HandleKeyPressEP14nsIDOMKeyEvent+0x000001EF
[/usr/lib/mozilla-1.8a1/components/libeditor.so +0x00081E6F]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libeditor.so +0x00115AB3]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libgklayout.so +0x0059752D]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libgklayout.so +0x0059AC15]
_ZN10nsDocument14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus+0x000000D7
[/usr/lib/mozilla-1.8a1/compone
nts/libgklayout.so +0x004ECE57]
_ZN16nsGenericElement14HandleDOMEventEP14nsIPresContextP7nsEventPP11nsIDOMEventjP13nsEventStatus+0x00000532
[/usr/lib/mozilla-1.8a1/c
omponents/libgklayout.so +0x00522732]
_ZN9PresShell19HandleEventInternalEP7nsEventP7nsIViewjP13nsEventStatus+0x00000369
[/usr/lib/mozilla-1.8a1/components/libgklayout.so +
0x00382469]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libgklayout.so +0x00381925]
_ZN13nsViewManager11HandleEventEP6nsViewP10nsGUIEventi+0x0000055D
[/usr/lib/mozilla-1.8a1/components/libgklayout.so +0x0074765D]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libgklayout.so +0x007469A1]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libgklayout.so +0x0073C8CB]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libwidget_gtk2.so +0x000361B4]
_ZN8nsWindow15OnKeyPressEventEP10_GtkWidgetP12_GdkEventKey+0x000001BD
[/usr/lib/mozilla-1.8a1/components/libwidget_gtk2.so +0x000270B
D]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libwidget_gtk2.so +0x0002B553]
UNKNOWN [/usr/lib/libgtk-x11-2.0.so.0 +0x0010BDB0]
g_closure_invoke+0x000000A9 [/usr/lib/libgobject-2.0.so.0 +0x00008FC9]
UNKNOWN [/usr/lib/libgobject-2.0.so.0 +0x0001BEB4]
g_signal_emit_valist+0x000004FD [/usr/lib/libgobject-2.0.so.0 +0x0001ACED]
g_signal_emit+0x00000034 [/usr/lib/libgobject-2.0.so.0 +0x0001B1F4]
UNKNOWN [/usr/lib/libgtk-x11-2.0.so.0 +0x00203C89]
gtk_window_propagate_key_event+0x000000CF [/usr/lib/libgtk-x11-2.0.so.0 +0x002114CF]
UNKNOWN [/usr/lib/libgtk-x11-2.0.so.0 +0x00211567]
UNKNOWN [/usr/lib/libgtk-x11-2.0.so.0 +0x0010BDB0]
UNKNOWN [/usr/lib/libgobject-2.0.so.0 +0x00009317]
g_closure_invoke+0x000000A9 [/usr/lib/libgobject-2.0.so.0 +0x00008FC9]
UNKNOWN [/usr/lib/libgobject-2.0.so.0 +0x0001B90A]
g_signal_emit_valist+0x000004FD [/usr/lib/libgobject-2.0.so.0 +0x0001ACED]
g_signal_emit+0x00000034 [/usr/lib/libgobject-2.0.so.0 +0x0001B1F4]
UNKNOWN [/usr/lib/libgtk-x11-2.0.so.0 +0x00203C89]
gtk_propagate_event+0x00000167 [/usr/lib/libgtk-x11-2.0.so.0 +0x0010A507]
gtk_main_do_event+0x000001F7 [/usr/lib/libgtk-x11-2.0.so.0 +0x00109207]
UNKNOWN [/usr/lib/libgdk-x11-2.0.so.0 +0x0003CDD5]
UNKNOWN [/usr/lib/libglib-2.0.so.0 +0x00022938]
g_main_context_dispatch+0x00000092 [/usr/lib/libglib-2.0.so.0 +0x000239B2]
UNKNOWN [/usr/lib/libglib-2.0.so.0 +0x00023CDF]
g_main_loop_run+0x00000163 [/usr/lib/libglib-2.0.so.0 +0x000242F3]
gtk_main+0x000000B3 [/usr/lib/libgtk-x11-2.0.so.0 +0x00108B13]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libwidget_gtk2.so +0x00033742]
UNKNOWN [/usr/lib/mozilla-1.8a1/components/libnsappshell.so +0x000457EA]
UNKNOWN [/usr/lib/mozilla-1.8a1/mozilla-bin +0x0001BA8E]
main+0x000001FB [/usr/lib/mozilla-1.8a1/mozilla-bin +0x000189BB]
__libc_start_main+0x000000C6 [/lib/libc.so.6 +0x00015886]
Sleeping for 5 minutes.

Comment 6

14 years ago
that backtrace doesn't look like anything i saw in gdb...
Suspecting this is a dup of topcrash 1.8a1 bug 243809..
When did you last pull sources? 1.8a1 is old..
Can you confirm that you're building with the patch from bug 243809?
(Reporter)

Comment 7

14 years ago
the patch solve the crash issue but now the splitting of the left blue bar don't
occurs anymore....
so I can add text but it'll be see by the replied people like an original quoted
message.... 

Comment 8

14 years ago
to comment 7:
that would be another bug. Resolving as dup
(perhaps you should clobber..)

*** This bug has been marked as a duplicate of 243809 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.