[FLOAT] Overlapping text and pictures

VERIFIED FIXED in M16

Status

()

Core
Layout
P2
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Sitsofe Wheeler, Assigned: buster)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Steps to reproduce:
Visit http://windowsmagazine.com/columns/explorer/2000/02.htm

Expected:
Layout similar to Netscape 4.7

Result:
Layout problems at the top with overlapping tables pictures and text. Clicking
on normal text turns it red.

Build ID: 2000012116 Linux

Comment 1

19 years ago
Created attachment 4467 [details]
Testcase

Comment 2

19 years ago
"text turns red when clicked" is a duplicate of bug 23209. Removing that from
Summary. I have attached a testcase for the "overlapping" problem above.
It's that <SCRIPT></SCRIPT> causing problems in table layout again. I have seen
this in 3 or 4 bug reports lately.
Keywords: testcase
OS: Linux → All
Hardware: PC → All
Summary: Overlapping text and pictures, text turns red when clicked → Overlapping text and pictures
Whiteboard: [TESTCASE]

Comment 3

19 years ago
Floater problem. Note that we're asserting in the block code about bad floater 
placement
Assignee: troy → kipp

Comment 4

19 years ago
The testcase works fine in Jan 31 build (probably due to the fix of bug 23235).
But the URL still has overlapping content. This bug needs a new testcase.
Keywords: testcase
Whiteboard: [TESTCASE]
(Assignee)

Comment 5

19 years ago
floater layout problem, targeting for M15
Priority: P3 → P2
Summary: Overlapping text and pictures → [FLOAT] Overlapping text and pictures
Whiteboard: testcase needed -- reported that the attached testcase works, but the original URL is still broken
Target Milestone: M15
This no longer seems to be a problem with the <SCRIPT> tags. It now seems to be 
interaction between an initial <IMG> float and any following <P> blocks (on 
non-wrapping lines. See the following testcase.

build 2000022908
Keywords: testcase
Whiteboard: testcase needed -- reported that the attached testcase works, but the original URL is still broken → original testcase works, url is still broken; see new testcase
Rats. Forgot the image I used in the testcase. Any old image should do, but note 
that if you use image scaling, I found that the testcase *will* render properly.
(Assignee)

Comment 9

19 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
(Assignee)

Comment 10

19 years ago
a really interesting point is a simple test case using the same source, but 
adding javascript and a button to set the width of the image dynamically, works 
just fine.
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Whiteboard: original testcase works, url is still broken; see new testcase → fix in hand

Comment 11

19 years ago
moving all buster m15 bugs to m16.
Target Milestone: M15 → M16
(Assignee)

Comment 12

18 years ago
fix checked in.  should be able to verify against 4/17/00 build.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: fix in hand

Comment 13

18 years ago
Fixed in the April 21 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.