Toolbar buttons for Extensions and Themes (managers)

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
15 years ago
11 years ago

People

(Reporter: gkn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7) Gecko/20040614 Firefox/0.9

There should be toolbar buttons for the Extension and Theme managers.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Why, all other buttons are used all the time.
Themes and extensions are something one should only occasionally use.
(Reporter)

Comment 2

15 years ago
Some people add extensions or change themes quite frequently. Others needn't
have the buttons on their toolbars.

Comment 3

15 years ago
Confirming as enhancement request. Suggesting WONTFIX. We shouldn't clutter the
customize toolbar window with everything but the kitchen sink.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
I'm sure there's some enterprising extension hacker out there that could create
an extension that does this.

Well there's already a toolbar button for Downloads, so for consistency's sake,
why not the other two managers?  On the other hand, I agree with Simon that
these buttons would just be clutter, especially when the managers can be
accessed from the Tools menu with just two clicks, or even a click-drag-release.
 This is most likely extension territory, and should probably be left out by
default.

In fact...
just checked the forums:
http://forums.mozillazine.org/viewtopic.php?t=93924
(Reporter)

Comment 5

14 years ago
WONTFIXing since there's an extension to do this.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Greg: we're not wonfixing bugs when ther is an extenstion.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 7

14 years ago
this should be fairly easy to do

Updated

13 years ago
Assignee: bugs → nobody
Status: REOPENED → NEW
QA Contact: bugzilla → toolbars
The addons window doesn't even rate a keyboard shortcut, I don't think it needs a toolbar button.
Status: NEW → RESOLVED
Last Resolved: 14 years ago11 years ago
Resolution: --- → WONTFIX

Comment 9

11 years ago
Created attachment 322350 [details]
AMO screencap of Addons button extension downloads in the last week

(In reply to comment #8)
> The addons window doesn't even rate a keyboard shortcut, I don't think it needs
> a toolbar button.

2,488 people in the last 7 days disgree.
You need to log in before you can comment on or make changes to this bug.