wrong cell height when image inside

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: ogogog, Assigned: peterv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

In a template, I have a table with an 5x12 image inside, and no space around.
However the cell will always render as if there were spaces around, according
to the font size. Changing the css font size changes the cell height.

Here is the xml (very basic since it doesn't depend on it):

=============================================
<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="test.xsl"?>
<root></root>
=============================================

and now the xslt:
=============================================
<?xml version="1.0" encoding="utf-8"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" >
<xsl:output encoding="iso-8859-1"/>

<xsl:template match='/'>
<html>
<body>
<table border='1' cellpadding='0' cellspacing='0' height='5' width='12'>
  <tr height='5' width='12'>
    <td height='5' width='12' style='font-size:10px;'
    ><img src='../icoF.gif' height='5' width='12'
    /></td>
  </tr>
</table>
</body>
</html>
</xsl:template>

</xsl:stylesheet>
=============================================


Reproducible: Always
Steps to Reproduce:
1. save xml as test.xml
2. save xslt as test.xsl
3. render in brower

Actual Results:  
table/cell height incorrect/too high

Expected Results:  
table/cell height should adjust to img height

Comment 1

15 years ago
see http://devedge.netscape.com/viewsource/2002/img-table/ on why img tags have
line height in standards mode (which is all XSLT output supports)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.