Ctrl+Return in address bar does not resolve keywords

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: kuno.meyer, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

the keyword substitution in Firefox address bar does not work in combination
with Ctrl+Return (=opening the url in a new tab).

Having defined a bookmark like this:
   keyword=leo
   url=http://dict.leo.org/?search=%s

Enter in address bar
   leo evening <Ctrl>+<Return>

Expected result:
   Firefox opens new tab with address "http://dict.leo.org/?search=evening"

Actual result:
   - Firefox does not open a new tab
   - incorrect url completion to "http://www.leo evening.com"
   - Messagebox "Url is not valid and cannot be loaded."

Reproducible: Always
Steps to Reproduce:

Comment 1

15 years ago
<ctrl>+<return> is not the correct key combination for opening a new tab from
the url bar.  You need to use <alt>+<return> for this to work.  Using keywords
with <alt>+<return> works for me.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
(Reporter)

Comment 2

15 years ago
You are right -- I still was used to the Mozilla way of life.

To conclude:

- <Alt>+<Enter>: Open in new tab
- <Ctrl>+<Enter>: Extend input with "www." and ".com"
- <Enter> (great idea for non-US users): If domain name doesnot exist: take
first search result from google
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.