Closed Bug 247939 Opened 19 years ago Closed 19 years ago

Changing the theme removes all open pages

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 245327

People

(Reporter: bogdanb, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When changing the theme, all windows and tabs become empty (funny though, the
icons are still on the tabs). All windows and tabs are still open, though. All
address/history info dissapears from the address bar and prev/next buttons
(though the Go menu OK). 

This is very annoying, especially since it's unexpected: I just completed a
(lengthy) bug report and changed the theme to check if the bug occurs in another
theme, and I had to retype everything.

Reproducible: Always
Steps to Reproduce:
1. Open some pages (in a few windows/tabs, one is enough)
2. Masochistic people: spend half an hour filling some forms, don't click submit.
3. Change theme

Actual Results:  
All tabs/windows are now empty.

Expected Results:  
Change the theme, keep the window content.
I just noticed that after changing the theme this way, back and forward buttons
don't seem to work at all - even after loading new pages and clicking links. All
resumes to normal after restarting Firefox. The themes I tried switching between
are the default (Firefox 2.0, from Firefox 0.9) and Mostly Crystal 1.0

*** This bug has been marked as a duplicate of 245327 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
How the hell did I miss 245327? Sorry!
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.