Note: There are a few cases of duplicates in user autocompletion which are being worked on.

popup blocker should allow mouseup by default

RESOLVED FIXED in mozilla1.8alpha2

Status

SeaMonkey
UI Design
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Dan M, Assigned: Dan M)

Tracking

({fixed-aviary1.0, fixed1.7})

Trunk
mozilla1.8alpha2
fixed-aviary1.0, fixed1.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
Dangit. We missed a real problem. It happens that XUL command handlers are fired
in the mouseup event. So with window.open ignored in mouseup by default, remote
XUL like this
<command oncommand="window.open(...)">
is blocked.

I suppose the best thing would be to add mouseup to the default list of events.
(Assignee)

Comment 1

13 years ago
Created attachment 151367 [details] [diff] [review]
allow mouseup by default
(Assignee)

Updated

13 years ago
Attachment #151367 - Flags: superreview?(jst)
Attachment #151367 - Flags: review?(bzbarsky)
Comment on attachment 151367 [details] [diff] [review]
allow mouseup by default

r+sr=jst (bzbarsky is out of reach until mid-july or so, IIRC)
Attachment #151367 - Flags: superreview?(jst)
Attachment #151367 - Flags: superreview+
Attachment #151367 - Flags: review?(bzbarsky)
Attachment #151367 - Flags: review+
(Assignee)

Updated

13 years ago
Attachment #151367 - Flags: approval1.7.1?

Comment 3

13 years ago
Comment on attachment 151367 [details] [diff] [review]
allow mouseup by default

a=mkaply for 1.7.1
Attachment #151367 - Flags: approval1.7.1? → approval1.7.1+
(Assignee)

Comment 4

13 years ago
Actually I'm not certain we have to do this. It's beginning to look as if remote
XUL needs to be privileged enough to open as chrome (bug 244766, bug 244965)
before it can be useful anyway (bug 248004). And that would obviate the need for
this change. Holding off for now.
(Assignee)

Comment 5

13 years ago
Alright. mouseup (unlike mousedown!) is fairly innocuous and kin to click. Also,
not all remote XUL need necessarily be privileged. So the patch is checked in to
the trunk for 1.8a2 and the 1.7 branch for 1.7.1.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8alpha2

Comment 6

13 years ago
The patch is not checkined yet to AVIARY_1_0_20040515_BRANCH.
Please checkin to AVIARY_1_0_20040515_BRANCH.
(Assignee)

Comment 7

13 years ago
Now also checked in on the Aviary branch for 0.9.1+.

Updated

13 years ago
Keywords: fixed-aviary1.0, fixed1.7
(Assignee)

Comment 8

13 years ago
(About comment 5: this change is indeed on the 1.7 branch, but will not be
picked up in a release that hasn't synched with the main 1.7 branch. To date no
1.7.x release has done this.)
(Assignee)

Comment 9

13 years ago
*** Bug 267208 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.