cannot send messages to a.b.@mydomain.tld

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Florian Effenberger, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

I cannot send messages to a.b.@mydomain.tld. It automatically becomes cannot
send messages to "a.b."@mydomain.tld, which is wrong.

Reproducible: Always
Steps to Reproduce:
1. Compose a message.
2. Send it to a.b.@mydomain.tld
3.

Actual Results:  
It is being send to "a.b."@mydomain.tld

Expected Results:  
It should be send to a.b.@mydomain.tld

Comment 1

14 years ago
I can't test this since a.b.@mydomain.tld is no real address (maybe you can mail
me the real address to test this).
Who sends you the "cannot send" message (Mozilla or does Mozilla just cite a
server message) and what is the exact wording?
I can't reproduce the adding of "" with an local part of a.b., but in general
quoting of local-part is allowed. See RFC 2822, chapters 3.4.1. and 3.2.5.
(Reporter)

Comment 2

14 years ago
Thunderbird cites a server message, it get a postmaster notification, meaning
that TB sent out with "a.b."@mydomain.tld as recipient.
(Reporter)

Comment 3

14 years ago
TB is version 0.7 on WinXP.
(Reporter)

Comment 4

14 years ago
The tips on http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#smtp
did not work (no log file got created), however, it does NOT seem to be a bug
related to Thunderbird. I tried with another account, it does work in here, so
it seems to be a bug in the SMTP server.

Please check on your side whether you have this bug, too. If not, we can close
this bug. Sorry for the confusion.
(Reporter)

Comment 5

14 years ago
According to an expert: "That form must be quoted, see the RFC."
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.