Resizing Extensions dialog shows window contents while dragging (ignores system settings)

RESOLVED DUPLICATE of bug 185533

Status

()

Toolkit
Add-ons Manager
--
minor
RESOLVED DUPLICATE of bug 185533
14 years ago
10 years ago

People

(Reporter: Prasenjeet Dutta, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Seapony/0.9 (Firefox/0.9)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Seapony/0.9 (Firefox/0.9)

On Windows 2000 machines set to use outline dragging, resizing the Extensions
dialog using the bottom-right ridged "sizer" causes solid-dragging. This bug can
also be seen in the Themes and Downloads dialog.

Reproducible: Always
Steps to Reproduce:
1. On your Windows desktop, choose Start|Settings|Control Panel.
2. Open the Display applet and choose the Effects tab.
3. Make sure "Show window contents while dragging" is _unchecked_.
4. Open Firefox and choose Tools|Extensions.
5. Move your mouse over to the ridged "sizer" in the Bottom Right
   corner so that your cursor turns into a doubleheaded NW/SE cursor.
6. Make sure your cursor is nearly in the middle of the sizer, as shown
   in http://www.chaoszone.org/misc/mozilla/solid-dragging-bug-3.png
7. Click and drag the window around (to resize it).

Actual Results:  
Window contents are shown while the dialog is being resized. (This is also
called "solid dragging".)

Expected Results:  
The window contents should _not_ have been shown while being resized (a.k.a
"outline dragging").

Note that for the following positions _near_ the sizer, solid dragging does
_not_ occur:
http://www.chaoszone.org/misc/mozilla/solid-dragging-bug-1.png
http://www.chaoszone.org/misc/mozilla/solid-dragging-bug-2.png

This bug would be a minor one but it is exacerbated by the fact that painting
the Extensions (and Downloads, and Themes) dialog seems to be a very slow
affair, especially on machines with mediocre video cards. On my old Thinkpad T20
with an S3/Savage IX (8MB video RAM), the system stutters while painting these
dialogs during a resize or scroll. Someone may wish to investigate this as a
separate bug.

Comment 1

14 years ago
I have also noticed this behavior in the main browser window.  If you resize by
grabbing the very edge of the window the resize pays attention to the system
setting.  If you grab the resizer, as noted in the first comment, the window
contents are shown while resizing the window.

Comment 2

14 years ago
Does it still ignore it in Firefox 1.0?
Severity: normal → minor
Component: General → Extension/Theme Manager
(Reporter)

Comment 3

14 years ago
Created attachment 166419 [details]
Screenshot of where Firefox 1.0 still solid-drags

In firefox 1.0, http://www.chaoszone.org/misc/mozilla/solid-dragging-bug-3.png
is fixed, it honors the outline drag pref now.

However there is stil a case where it solid-drags, I've created an attachment
that shows where.

Comment 4

14 years ago
Confirmed on WinXP, Firefox 1.0

1. My computer -> properties -> advanced -> performance -> settings -> custom ->
uncheck "show window contents while dragging".
2. Tools -> Themes or Tools -> Extensions
3. Drag the grippie (not the border itself!) in the down-right corner (as on
screenshot). The window content will be redrawn, some visual artifacts may be
visible.

similar action works correctly with native win32 applications, like foobar2000
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → Windows XP
Summary: Resizing using Sizer in Extensions dialog ignores system settings, always shows window contents while dragging → Resizing Extensions dialog shows window contents while dragging (ignores system settings)

*** This bug has been marked as a duplicate of 185533 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.