If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attempting 'Save As' caused the browser to stop loading urls - constant 'Loading' message

RESOLVED INVALID

Status

Camino Graveyard
Downloading
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Ben Fowler, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040531 Firefox/0.8.0+
Build Identifier: Camino 0.8b May 2004

I was trying to Save a page with Ctrl-S, and the browser stopped doing anything
(no feedback). Perhaps it was trying to download a new copy from a slow server.
I tried a few menus to try to work out what was going on, and at one point
there was a 'Save' dialogue obscured by the Window menu - the latter not
responding to the ESC key.

Thereafter Camino would not download new pages such as Google, or even more
importantly the Mozilla Bugzilla page.

It does, though, handle the currently open pages correctly.

Reproducible: Didn't try
Steps to Reproduce:
1. Try to Save a page from a slow server
2. ??
3. ??

Actual Results:  
Browser stopped browsing

Expected Results:  
Should give feedback; and if it was, should not download a fresh page to Save, but
that is an existing Bug.

I saw this message in Console, but it may be irrelevant:

2004-06-22 13:59:02.663 Camino[26349] *** NSTimer ignoring exception
'NSRangeException' (reason '*** -[NSCFArray objectAtIndex:]: index (4) beyond
bounds (0)') that raised during posting of timer with target 23eda20 and
selector 'eventTimer:'
(Assignee)

Comment 1

13 years ago
yeah, that exception would stop the entire browser window from working, maybe
eeven the whole app.

can you reproduce this at all? i've never seen it. can you provide a url for us
to test on?
(Reporter)

Comment 2

13 years ago
The URL I was on points to an internal server. I will try to
reproduce, but so far it hasn't happened.

Are there instructions for getting a backtrace. If the event
loop is working, I would expect an interrupt to break in
mach_msg_trap ()

( Camino 2004051715 (v0.8b) )

Comment 3

13 years ago
Closing bug, not enough info and I can't confirm (I have tried many times).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.