misplaced menupopup and tree when inside a deck which is in a box with scrollbar

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: mva, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.91 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

When placing a menulist with a menupopup inside a deck which itself is included in  
a box with css rule "overflow:scroll", if you scrolldown and click the menulist,
the menupopup is misplaced. If you place a tree in the same position, selecting
a treechildren is misplaced as well.

Reproducible: Always
Steps to Reproduce:
1.create a xul window with the following code:
<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin" type="text/css"?>
<window xmlns:html="http://www.w3.org/1999/xhtml"
        xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

    <vbox flex="1" style="overflow:scroll;">
        <description value="some content" height="400" minheight="400"/>
    
        <deck selectedIndex="0" flex="1">
            <vbox>
                <menulist label="Bus">
                    <menupopup>
                        <menuitem label="Car"/>
                        <menuitem label="Taxi"/>
                        <menuitem label="Bus" selected="true"/>
                        <menuitem label="Train"/>
                    </menupopup>
                </menulist>
                <tree flex="1" minheight="300">
                  <treecols>
                    <treecol id="sender" label="Sender" flex="1"/>
                    <treecol id="subject" label="Subject" flex="2"/>
                  </treecols>
                
                  <treechildren>
                    <treeitem>
                      <treerow>
                        <treecell label="joe@somewhere.com"/>
                        <treecell label="Top secret plans"/>
                      </treerow>
                    </treeitem>
                    <treeitem>
                      <treerow>
                        <treecell label="joe@somewhere.com"/>
                        <treecell label="Top secret plans"/>
                      </treerow>
                    </treeitem>
                    <treeitem>
                      <treerow>
                        <treecell label="joe@somewhere.com"/>
                        <treecell label="Top secret plans"/>
                      </treerow>
                    </treeitem>
                  </treechildren>
                </tree>
            </vbox>
        </deck>
    </vbox>
</window>
2. open the xul file and make sure your window is small enough to scroll down 
to the menulist and tree.
3.click on the menulist, and try to select a treechildren

Actual Results:  
the menupopup is misplaced
and the wrong treechildren is selected.

Expected Results:  
place the popup correctly and select the correct treechildren

<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin" type="text/css"?>
<window xmlns:html="http://www.w3.org/1999/xhtml"
        xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

    <vbox flex="1" style="overflow:scroll;">
        <description value="some content" height="400" minheight="400"/>
    
        <deck selectedIndex="0" flex="1">
            <vbox>
                <menulist label="Bus">
                    <menupopup>
                        <menuitem label="Car"/>
                        <menuitem label="Taxi"/>
                        <menuitem label="Bus" selected="true"/>
                        <menuitem label="Train"/>
                    </menupopup>
                </menulist>
                <tree flex="1" minheight="300">
                  <treecols>
                    <treecol id="sender" label="Sender" flex="1"/>
                    <treecol id="subject" label="Subject" flex="2"/>
                  </treecols>
                
                  <treechildren>
                    <treeitem>
                      <treerow>
                        <treecell label="joe@somewhere.com"/>
                        <treecell label="Top secret plans"/>
                      </treerow>
                    </treeitem>
                    <treeitem>
                      <treerow>
                        <treecell label="joe@somewhere.com"/>
                        <treecell label="Top secret plans"/>
                      </treerow>
                    </treeitem>
                    <treeitem>
                      <treerow>
                        <treecell label="joe@somewhere.com"/>
                        <treecell label="Top secret plans"/>
                      </treerow>
                    </treeitem>
                  </treechildren>
                </tree>
            </vbox>
        </deck>
    </vbox>
</window>

Comment 1

14 years ago
I see it with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050325 Firefox/1.0+ too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 2

14 years ago
Created attachment 179259 [details]
testcase from reporter
WFM, with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050903
Firefox/1.6a1

Comment 4

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051110 Firefox/1.6a1

I tried to track down a dupe for this, but did not succeed. WFM on Windows and Linux; reopen if you can reproduce in the latest builds. 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.