FF09 startup crash [@ msvcrt.dll - dosprintf]

RESOLVED DUPLICATE of bug 247284

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 247284
14 years ago
7 years ago

People

(Reporter: jay, Assigned: Blake Ross)

Tracking

({crash, topcrash+})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
This is the #1 topcrash for Firefox 0.9.  Almost all the comments mention
startup.    More then 1/2 of the current 18K incidents are of this type.  Here
is just some of the Talkback data:

Rank    StackSignature    Count  

1   msvcrt.dll   9547 
 
====================================================================================================
     Count   Offset    Real Signature
[ 6748   msvcrt.dll + 0x3381c (0x77c4381c) b5977b87 - msvcrt.dll + 0x3381c
(0x77c4381c) ]
 
     Crash date range: 16-JUN-04 to 17-JUN-04
     Min/Max Seconds since last crash: 0 - 180610
     Min/Max Runtime: -55211 - 189484
 
     Count   Platform List 
     6738   [Windows NT 5.1 build 2600]   
     8   [Windows NT 5.0 build 2195]   
     1   []       
     1   [Windows NT 4.0 build 1381]   
 
     Count   Build Id List 
     6748   2004061423
 
     No of Unique Users      2554
 
 Stack trace(Frame) 

	 msvcrt.dll + 0x3381c (0x77c4381c)  
	 dosprintf
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/jsprf.c 
line 957] 
	 JS_vsmprintf
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/jsprf.c 
line 1104] 
	 JS_smprintf
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/jsprf.c 
line 1082] 
	 XPCConvert::JSErrorToXPCException
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcconvert.cpp
 line 1413] 
	 XPCConvert::JSValToXPCException
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcconvert.cpp
 line 1245] 
	 nsXPCWrappedJSClass::CheckForException
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp
 line 826] 
	 nsXPCWrappedJSClass::CallMethod
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp
 line 1370] 
	 nsXPCWrappedJS::CallMethod
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp
 line 450] 
	 SharedStub
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp
 line 147] 
	 RDFXMLDataSourceImpl::EndLoad
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/rdf/base/src/nsRDFXMLDataSource.cpp
 line 1059] 
	 RDFContentSinkImpl::DidBuildModel
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/rdf/base/src/nsRDFContentSink.cpp
 line 670] 
	 CNavDTD::DidBuildModel
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 707] 
	 nsParser::DidBuildModel
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsParser.cpp
 line 1245]  
 
     (124599)	Comments: After a reinstallation (and another reboot)  I'm still
not able to run firefox.  Hopefully this is something obvious and I'll be able
to find something about it on bugzilla (using another browser  of course).
     (124567)	Comments: Starting Up Firefox and it died
     (124565)	Comments: starting up
     (124562)	Comments: launching Firefox
     (124560)	Comments: Firefox is crashing as soon as I launch it. 
     (124557)	Comments: Opening Firefox with Outlook Express running.
     (124547)	Comments: opening firefox
     (122213)	Comments: starting it
     (122183)	Comments: On launch  firefox is dying.
     (122172)	Comments: when double click de icon  Firefox open and the Quality
Feedback Agent told me that there was an error   Only can add that my Home Page
is www.google .com
     (122138)	Comments: error occurs when I start firefox in Windows XP pro
     (122123)	Comments: Crashed on startup for fourth time in a row - going back
to Mozilla 1.6 for time being
     (122116)	URL: http://www.google.com
     (122116)	Comments: Trying to launchthe page from
Start->Run->http://www.google.com    Seems to have been after an instance
of Firefox that was eating about 250Mb of memory was closed down - that instance
had been running for a few days  so I suspect a memory leak.
     (122115)	Comments: opening the program
     (122043)	URL: http://127.0.0.1/
     (122043)	Comments: And again!
     (122007)	Comments: Loading Firefox 0.9
     (122003)	URL: http://127.0.0.1/
     (122003)	Comments: Starting up again.  Firefox refuses to start without
crashing.  
     (121993)	Comments: opening the browser
     (121976)	URL: www.yahoo.com

Any idea what might be going on from looking at the stack?  The comments aren't
very useful...but if you want to see more, just go to:
http://talkback-public.mozilla.org/reports/FF09/smart-analysis.win
(Reporter)

Comment 1

14 years ago
dup of bug 247284?

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 247284 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ msvcrt.dll - dosprintf]
You need to log in before you can comment on or make changes to this bug.