When I save a page containing empty XHTML tags(e.g <br />), the empty tag gets replaced with its HTML4 equivalent(e.g <br /> to <br>)

RESOLVED DUPLICATE of bug 120556

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 120556
14 years ago
14 years ago

People

(Reporter: Nicholas Skehin, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040621 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040621 Firefox/0.9

All empty XHTML tags have the closing / removed - so they become <tagname>
instead of <tagname/> or <tagname />.

Reproducible: Always
Steps to Reproduce:
1. Go to http://alistapart.com (for instance)
2. Save the page to a file.

Actual Results:  
All the <br /> tags in the page became <br>. 

Expected Results:  
Left the page as it is.

I've built Mozilla Firefox under Gentoo Linux with custom CFLAGS, but I can't
see how things this would affect it. Other than that, my system is fairly normal.
(Reporter)

Comment 1

14 years ago
Created attachment 151472 [details]
What Mozilla Firefox saved the page as.
(Reporter)

Comment 2

14 years ago
Created attachment 151473 [details]
What it should be saved as.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040621
Firefox/0.9.0+

same as under Linux

I saved as webpage complete, the saved file still had <br> i/o <br/>
what about either of the other two options?  I know that the web page complete
option basically takes the contents of the DOM and generates the files with the
right names, not necessarily as the exact source as sent.

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 120556 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.