After clearing cache, changed preferences do not save

VERIFIED FIXED

Status

()

Firefox
Preferences
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: Peter Weilbacher, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8a2) Gecko/20040618
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7) Gecko/20040616 Firefox/0.9

This is a very obvious bug, but I didn't find any dupes...

Reproducible: Always
Steps to Reproduce:
1. Clear the cache with Tools->Options->Privacy->Cache->Clear
2. Change any other preference
3. Press OK

Actual Results:  
A window appears saying "Failed to save the preferences file. Any preference
changes will be lost at the end of this session."

Expected Results:  
Save the changed prefs.

Hmm, the call this.pref.savePrefFile(null); in 
browser/components/prefwindow/content/nsPrefWindow.js line 255 seems to throw
and error and hence display this message. Couldn't even find out where
savePrefFile() is defined...
(Assignee)

Comment 1

14 years ago
This bug is definitely happening in ff 0.9, but I do not see it in a current
build of the firefox branch...
(Assignee)

Comment 2

14 years ago
Created attachment 151636 [details] [diff] [review]
Don't optimize nsPrefService.cpp on OS/2

This is an optimizer bug in GCC 3.2.2

Fix is not to optimize nsPrefService
Assignee: firefox → mkaply
Status: UNCONFIRMED → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #151636 - Flags: review?(jhpedemonte)

Updated

14 years ago
Attachment #151636 - Flags: review?(jhpedemonte) → review+
(Assignee)

Comment 3

14 years ago
Fix checked in to trunk and aviary. Noone sees this on 1.7, so I am not putting
it there.

The reason I put it on the trunk is because firefox will be moving back to the
trunk at some point.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

14 years ago
I managed to finally get it built, and I can confirm that this issue is fixed.

But should this not really be fixed (by Innotek) in GCC if it is an optimizing bug?
Status: RESOLVED → VERIFIED
(Assignee)

Comment 5

14 years ago
They think it is probably fixed in the new GCC, but that won't be released in
the very near future.

As soon as they release a new GCC, I'll retest this and remove the patch if
necessary.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.