If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

editing mail filters in deferred account uses deferred to account

RESOLVED FIXED

Status

MailNews Core
Filters
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

Trunk
x86
Windows XP
fixed-aviary1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
editing mail filters in deferred account uses deferred to account

Comment 1

13 years ago
(In reply to comment #0)
> editing mail filters in deferred account uses deferred to account

I think you would find most (all?) people using global inbox prefer this
behaviour (if filters would also apply to messages retrieved from deferred
accounts).

So long as there were an additional filter condition for 'Originating account'.
(Assignee)

Comment 2

13 years ago
yes, ultimately we'd like to be able to have filters on both accounts apply, but
right now, by default, pop3 accounts defer to the local folders account, and we
don't let you edit filters in the local folders account, so I think I need to
fix this.
(Assignee)

Comment 3

13 years ago
>Thread view is sometimes not remembered.  Expansion/collapse is never
>remembered.  Message unread counts are not correct.

>It appears this occurs when Windoze crashes and Tbird doesn't close normally. 

I'm confused - are all of these a problem only when windows/tbird crashes? Or
are some of them always a problem, and others a problem only when tbird doesn't
shut down cleanly? E.g., you save expand/collapse is never remembered, but it is
for me, at least after a normal shutdown.
(Assignee)

Comment 4

13 years ago
Created attachment 154114 [details] [diff] [review]
proposed fix

use per-server filters for now, since we don't have an account criteria.
(Assignee)

Comment 5

13 years ago
Comment on attachment 154114 [details] [diff] [review]
proposed fix

I really need to have a better name for GetRootFolder, so that it's clear we're
getting the actual root, and not the place where we're deferring storage to...
Attachment #154114 - Flags: superreview?(mscott)

Updated

13 years ago
Attachment #154114 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 6

13 years ago
fix checked in. If there's not a bug open about applying two sets of filters for
deferred accounts, (one for the originating server, one for the deferred to
server/account), I'll file one.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 7

13 years ago
(In reply to comment #6)
> fix checked in. If there's not a bug open about applying two sets of filters for
> deferred accounts, (one for the originating server, one for the deferred to
> server/account), I'll file one.

David, I couldn't find a bug about this. Have you forgotten about it or is it
just me being blind? ;-)
(Assignee)

Comment 8

13 years ago
I haven't even gotten around to searching for an existing bug. But I'll take
your word for it that there's no existing bug and file a new one.
(Assignee)

Comment 9

13 years ago
Bug 257979 filed for applying multiple filter lists for deferred accounts.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.