Tables using colspan is corrupted when dynamicly setting display to none|block

RESOLVED DUPLICATE of bug 97506

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 97506
14 years ago
14 years ago

People

(Reporter: Morten Fangel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

When creating a table with min. 2 rows where one of them are using colspan="NN",
then via JS setting style.display to none, then changing it back to block will
cause Moz to 'forget' about the colspan setting, and the table is corrupted...

Check the URL to see an example code which shows the problem...

Reproducible: Always
Steps to Reproduce:
1. Create a table with min. 2 rows, one using colspan
2. Change style.display to 'none'
3. Change it back to 'block'

Actual Results:  
Table layout is corrupted because Moz forgots about colspan="NN", also a
block-line is added to the table

Expected Results:  
The row with colspan should have just dissapeared, then re-emerged to its orig.
setting

Comment 1

14 years ago
since when rows have display: block instead of table-row?

*** This bug has been marked as a duplicate of 97506 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.